summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJoan Bruguera2019-03-22 17:27:46 +0100
committerJoan Bruguera2019-03-22 17:27:46 +0100
commit82156a4d5569c028fb6901b110cd8906ff3c8ccd (patch)
tree4c097976be9b33da25d79b6b7331e3315ab8ce36 /PKGBUILD
parent61b6d5a534f404c1778e25fa03fed55f978b0354 (diff)
downloadaur-82156a4d5569c028fb6901b110cd8906ff3c8ccd.tar.gz
Lint and uniformize BSC package files.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 5 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5dee54bd644a..68de624b451d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,21 +2,23 @@
pkgname='basicanalysis'
pkgdesc='Framework for automatic extraction of fundamental factors for Paraver traces (from BSC).'
pkgver='0.3.6'
-pkgrel='1'
+pkgrel='2'
arch=('any')
url='https://www.bsc.es/discover-bsc/organisation/scientific-structure/performance-tools'
license=('LGPLv2.1')
-depends=(python-scipy python-numpy)
-optdepends=(gnuplot)
+depends=(python python-scipy python-numpy)
+optdepends=('gnuplot: For drawing the generated plots')
source=("https://ftp.tools.bsc.es/$pkgname/$pkgname-$pkgver-src.tar.bz2")
sha512sums=(94fac4171454978c1f3a27ec29e0c407413008b491ffe9aed2f7915ef9e5d3f7b2cdbc155ba00aa3e426b261ca259e1c00b59ffdde941bbb6a3cc49194827897)
package() {
+ # Install script and configurations in /usr/lib/basicanalysis
cd "$srcdir/$pkgname-$pkgver"
install -d -m755 "$pkgdir/usr/lib/basicanalysis/cfgs/"
install -D -m755 "modelfactors.py" "$pkgdir/usr/lib/basicanalysis/"
find "cfgs" -type f -exec install -D -m644 "{}" "$pkgdir/usr/lib/basicanalysis/cfgs/" \;
+ # Create a symlink to the script in /usr/bin for ease of use
mkdir -p -m755 "$pkgdir/usr/bin"
ln -s "/usr/lib/basicanalysis/modelfactors.py" "$pkgdir/usr/bin/modelfactors.py"
} \ No newline at end of file