summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTed Alff2017-11-18 09:31:12 -0500
committerTed Alff2017-11-18 09:31:12 -0500
commit68cac5ccfa3a2d9225f8e3ec7ebceaa96c78e5af (patch)
tree8f9c6bc275e5a59545487baf22fe2d3cb693d733 /PKGBUILD
downloadaur-68cac5ccfa3a2d9225f8e3ec7ebceaa96c78e5af.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f44ef578ae1b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: twa022 <twa022 at gmail dot com>
+
+_pkgname=basilisk
+pkgname=${_pkgname}-bin
+pkgver=55.0.2017.11.13
+pkgrel=1
+pkgdesc="Basilisk Browser from the makers of Pale Moon"
+url="http://www.basilisk-browser.org"
+arch=('x86_64')
+license=('GPL')
+dependsdepends=('gtk2' 'dbus-glib' 'libxt' 'mime-types' 'nss' 'alsa-lib' 'icu')
+optdepends=('hunspell: spell checker and morphological analyzer'
+ 'hyphen: library for hyphenation and justification'
+ 'ffmpeg: record, convert, and stream audio and video')
+source=("http://us.basilisk-browser.org/release/basilisk-latest.linux64.tar.bz2"
+ 'basilisk.desktop')
+sha256sums=('SKIP'
+ 'c4223e966bc404467fece4a524cc2db3e99c12455087da2ade9a47b8d99d3a45')
+
+pkgver() {
+ cd "${srcdir}"/basilisk
+ ./basilisk --version | grep -o -E '[0-9\.]+$'
+}
+
+package() {
+ mkdir -p "$pkgdir"/opt
+ cp -ar --no-preserve=ownership "$srcdir"/basilisk "$pkgdir"/opt
+ mkdir -p "${pkgdir}"/usr/bin
+ cat > "${pkgdir}"/usr/bin/basilisk <<- __EOF__
+ #!/bin/bash
+ /opt/basilisk/basilisk "\$@"
+ __EOF__
+ chmod 755 "${pkgdir}"/usr/bin/basilisk
+ install -Dm644 "${srcdir}"/basilisk.desktop "${pkgdir}"/usr/share/applications/basilisk.desktop
+ install -Dm644 "${srcdir}"/basilisk/browser/icons/mozicon128.png "${pkgdir}"/usr/share/pixmaps/basilisk.png
+}