summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorVincent Kobel2018-06-04 17:05:05 +0200
committerVincent Kobel2018-06-04 17:05:05 +0200
commitfc69e1b834cba923ce78c5082048a583c97ac647 (patch)
tree4e583436882f3e3a8bbf524750cb19d3b675efbe /PKGBUILD
downloadaur-fc69e1b834cba923ce78c5082048a583c97ac647.tar.gz
init
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8741525a4290
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Vincent Kobel (v@kobl.one)
+
+_pkgname='bat'
+pkgname="bat-cat-git"
+pkgver=r205.c91511c
+pkgrel=1
+pkgdesc="A cat(1) clone with wings."
+arch=('x86_64')
+url='https://github.com/sharkdp/bat'
+license=('Apache-2.0')
+sha256sums=('SKIP')
+source=("git+https://github.com/sharkdp/${_pkgname}")
+provides=('bat')
+makedepends=('git' 'rust')
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "${srcdir}/${_pkgname}"
+ cargo build
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}"
+ install -D ./target/debug/${_pkgname} "${pkgdir}/usr/bin/${_pkgname}"
+}
+