summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJ5lx2015-06-09 16:38:09 +0200
committerJ5lx2015-06-09 16:38:09 +0200
commite89ff48bd95076d03f65655cf4fa8a86524947e4 (patch)
treedac3692ed750d6f5ce581179a36dc8f75a8c62a8 /PKGBUILD
downloadaur-batsh.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..29bc5a4d67a6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Jakob Gahde <j5lx@fmail.co.uk>
+
+pkgname=batsh
+pkgver=0.0.6
+pkgrel=1
+license=('MIT')
+arch=('i686' 'x86_64')
+pkgdesc="A language that compiles to Bash and Windows Batch"
+url="https://github.com/BYVoid/Batsh"
+depends=('ocaml' 'ocaml-core' 'ocaml-ounit' 'ocaml-dlist' 'ocaml-cmdliner')
+makedepends=('ocp-build')
+source=("https://github.com/BYVoid/Batsh/archive/v${pkgver}.tar.gz")
+options=('!strip')
+md5sums=('aeb8a3a6b6c7c9de8b041dc9023b6a1a')
+
+build() {
+ cd "${srcdir}/Batsh-${pkgver}/src"
+
+ ocp-build init
+ ocp-build build
+}
+
+package() {
+ cd "${srcdir}/Batsh-${pkgver}/src"
+
+ ocp-build install -install-destdir $pkgdir
+}