summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSeverin Glöckner2021-03-03 20:46:59 +0100
committerSeverin Glöckner2021-03-03 20:50:01 +0100
commit011ae8023116d547b252f47db8654f7452cfb1b7 (patch)
tree30eaa0c32b8da0b3d0b5e2cd0f056458be87821f /PKGBUILD
parentfb0137e37ddfc72ce2fbf750c90c096cca670cce (diff)
downloadaur-011ae8023116d547b252f47db8654f7452cfb1b7.tar.gz
clean up dependency list
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD112
1 files changed, 61 insertions, 51 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 19ac48e84d09..3405ac1a4e0c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,58 +4,59 @@
pkgname="bbb-recorder-git"
pkgver=0.0.0+81
-pkgrel=1
+pkgrel=2
pkgdesc="Tool to download recordings from Big Blue Button"
arch=("any")
url="git+https://github.com/jibon57/bbb-recorder"
license=("MIT")
# 1:1 list of the debian packages in ./dependencies_check.sh.
-depends=('alsa-lib'
- 'atk'
- 'glibc'
- 'cairo'
- 'libcups'
- 'dbus'
- 'expat'
- 'fontconfig'
- 'gcc-libs'
- 'gconf'
- 'gdk-pixbuf2'
- 'glib2'
- 'gtk3'
- 'nspr'
- 'pango'
- 'gcc'
- 'libx11'
- 'libxcb'
- 'libxcomposite'
- 'libxcursor'
- 'libxdamage'
- 'libxext'
- 'libxfixes'
- 'libxi'
- 'libxrandr'
- 'libxrender'
- 'libxss'
- 'libxtst'
- 'ca-certificates'
- 'nss'
- 'xdg-utils'
- 'wget'
- 'xorg-server-xvfb')
-# Also part of the list, I SUPPOSE they MAY be optional.
-optdepends=('ttf-liberation: possibly required'
- 'libappindicator-gtk3: possibly required'
- 'lsb-release: possibly required'
- 'fonts-noto: possibly required')
+# But it looks more like the dependencies of chromium.
+depends=( # 'alsa-lib'
+ # 'atk'
+ # 'glibc'
+ # 'cairo'
+ # 'libcups'
+ # 'dbus'
+ # 'expat'
+ # 'fontconfig'
+ # 'gcc-libs'
+ # 'gconf'
+ # 'gdk-pixbuf2'
+ # 'glib2'
+ # 'gtk3'
+ # 'nspr'
+ # 'pango'
+ # 'gcc'
+ #'libx11'
+ #'libxcb'
+ #'libxcomposite'
+ #'libxcursor'
+ #'libxdamage'
+ #'libxext'
+ #'libxfixes'
+ #'libxi'
+ #'libxrandr'
+ #'libxrender'
+ #'libxss'
+ #'libxtst'
+ # 'ca-certificates'
+ # 'libappindicator-gtk3'
+ # 'ttf-liberation'
+ # 'nss'
+ # 'lsb-release'
+ # 'xdg-utils'
+ # 'wget'
+ 'xorg-server-xvfb'
+ # 'fonts-noto'
+ )
# Dependencies mentioned elsewhere:
depends+=('nodejs')
-optdepends+=('ffmpeg: converting webm to mp4')
-makedepends=('git' 'npm')
# Because it uses a hardcoded path (can be changed, see prepare function):
depends+=('chromium')
+optdepends+=('ffmpeg: converting webm to mp4')
+makedepends=('git' 'npm')
install=bbb-recorder.install
-source=(git+https://github.com/jibon57/bbb-recorder.git)
+source=("git+https://github.com/jibon57/bbb-recorder.git")
sha256sums=('SKIP')
pkgver() {
@@ -78,7 +79,7 @@ prepare() {
[[ \$# -lt 1 || \$# -gt 4 ]] && help=1
[ ! -d ~/Downloads ] && echo "Directory ~/Downloads not found!" && help=1
[ ! -f /opt/bbb-recorder/.env ] && echo "Configuration file /opt/bbb-recorder/.env was not created. See /opt/bbb-recorder/.env.example" && help=1
-if grep -s copyToPath /opt/bbb-recorder/.env | grep --quiet ~/Downloads$; then echo "The copyToPath cannot be you Downloads directory, because the video is temporarily stored there and later deleted!" && help=1; fi
+grep -s copyToPath /opt/bbb-recorder/.env | grep --quiet ~/Downloads$ && echo "The copyToPath cannot be you Downloads directory, because the video is temporarily stored there and later deleted!" && help=1
[[ \$2 == */* ]] && echo "The filename cannot be a path!" && help=1
[[ \${2%.webm} == *.* ]] && echo "No dots are allowed as part of the filname except for the file extension .webm!" && help=1
@@ -91,13 +92,17 @@ if [[ \$help -eq 1 ]]; then
echo '\$3: Duration of recording in seconds. 0 = real duration of recording (default).'
echo '\$4: Enter "true" to convert to mp4.'
else
- # Script would also work from any other directory as long as it has an ~/.env file in it.
+ # Script would also work from any other directory as long as it has an ./.env file in it.
cd /opt/bbb-recorder
exec node export.js "\$@"
fi
EOF
- sed s/export.js/liveJoin.js/ bbb-recorder-export.sh > bbb-recorder-livejoin.sh
+
+ sed -e "s/export.js/liveJoin.js/" \
+ -e "s/recording link/join link/" \
+ -e "s/real duration of recording/until the end of the meeting/" \
+ bbb-recorder-export.sh > bbb-recorder-livejoin.sh
cd "$srcdir"/bbb-recorder
# Google Chrome has a different filename than on Debain, need to change it to something else!
@@ -108,28 +113,33 @@ EOF
build() {
cd "$srcdir"/bbb-recorder
- npm install --ignore-scripts --no-progress --silent --no-fund --no-package-lock
- npm install --ignore-scripts --no-progress --silent --no-fund --no-package-lock examples
+ npm install --ignore-scripts --silent --no-package-lock
+ npm install --ignore-scripts --silent --no-package-lock examples
find -name package.json -exec sed -i '/_where/d' {} +
}
package() {
install -Dm755 bbb-recorder-export.sh "$pkgdir"/usr/bin/bbb-recorder
+
# AFAICT the other scripts are only usable if you adminstrate the BBB server too.
# install -Dm755 bbb-recorder-livejoin.sh "$pkgdir"/usr/bin/bbb-recorder-livejoin
# install -Dm755 bbb-recorder-broadcast.sh "$pkgdir"/usr/bin/bbb-recorder-broadcast
- # Storing it together with the node modules in /opt.
+ # Storing it together with the node modules in /opt, so that the node modules do not need to be installed globally.
install -Dm644 "$srcdir"/bbb-recorder/.env.example -t "$pkgdir"/opt/bbb-recorder/
cp -a "$srcdir"/bbb-recorder/* "$pkgdir"/opt/bbb-recorder/
# Did that already by listing them as package dependencies.
rm "$pkgdir"/opt/bbb-recorder/dependencies_check.sh
- # Need to do that differently (like in the bbb-recorder-git.install script).
+ # Need to do that differently (like in the bbb-recorder.install script).
# It even seems that the namespaceing for users is not needed.
rm "$pkgdir"/opt/bbb-recorder/namespace_checker.sh
- install -dm755 "$pkgdir"/usr/share/licenses/bbb-recorder/
- mv "$pkgdir"/opt/bbb-recorder/LICENSE "$pkgdir"/usr/share/licenses/bbb-recorder/
+ # Example script for usage with docker-compose, should not be used without it.
+ chmod 644 "$pkgdir"/opt/bbb-recorder/start_stream.sh
+ mv "$pkgdir"/opt/bbb-recorder/start_stream.sh "$pkgdir"/opt/bbb-recorder/docker-compose.start_stream.sh
+
+ install -dm755 "$pkgdir"/usr/share/licenses/$pkgname/
+ mv "$pkgdir"/opt/bbb-recorder/LICENSE "$pkgdir"/usr/share/licenses/$pkgname/
}