summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorduzhaokun1232022-07-23 21:55:32 +0800
committerduzhaokun1232022-07-23 21:55:32 +0800
commitcea8a163d47124487fb3e6c0af188041a95b04f4 (patch)
tree51c2fb3cab23632462bc612a28049a0424a0dab1 /PKGBUILD
parent2f77f8d2a4aa13aef19461c0aac22882b096cb6f (diff)
downloadaur-cea8a163d47124487fb3e6c0af188041a95b04f4.tar.gz
完善
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 4 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9802115826a0..43d0e4f90a9c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -20,12 +20,14 @@ pkgver() {
build() {
cd "$srcdir/BBDown"
- if "$CARCH" = "aarch64"
- then
+ if [ "$CARCH" == "aarch64" ]; then
+ msg2 "build for arm64"
dotnet publish BBDown -r linux-arm64 -c Release -o artifact
else
+ msg2 "build for x64"
dotnet publish BBDown -r linux-x64 -c Release -o artifact
fi
+ strip artifact/BBDown
}
package() {