summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorbilibili_xiaok2022-07-27 19:21:57 +0800
committerbilibili_xiaok2022-07-27 19:21:57 +0800
commitec885ca4b1851ee1a83a3ccc676d813bd61c5dc6 (patch)
treea2a45ea75e8c8dd2cda6c4d0b6914a15196a984f /PKGBUILD
parent1ddf2905ef7c1c95c81974e0e31d7f4b596f84a6 (diff)
downloadaur-ec885ca4b1851ee1a83a3ccc676d813bd61c5dc6.tar.gz
优化PKGBUILD架构判断
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 7 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1b2c8497e848..0701f2a8c69e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -19,15 +19,17 @@ pkgver() {
build() {
cd "$srcdir/BBDown"
- if [ "$CARCH" == "aarch64" ]; then
- msg2 "build for arm64"
- dotnet publish BBDown -r linux-arm64 -c Release -o artifact
- else
msg2 "build for x64"
dotnet publish BBDown -r linux-x64 -c Release -o artifact
- fi
strip artifact/BBDown
}
+build_aarch64() {
+ cd "$srcdir/BBDown"
+ msg2 "build for arm64"
+ dotnet publish BBDown -r linux-arm64 -c Release -o artifact
+ strip artifact/BBDown
+
+}
package() {
mkdir -p "$pkgdir/usr/bin"