summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKlaus Alexander Seistrup2023-11-29 08:27:03 +0100
committerKlaus Alexander Seistrup2023-11-29 08:27:03 +0100
commitf83a6d47e409931e881239ec48554d3fda9bc286 (patch)
tree0c8c2cf7421cea19d9978b08dac93a3ca3a195bb /PKGBUILD
parent8881c774bc3f82980a1f52729ae779a81b595d52 (diff)
downloadaur-f83a6d47e409931e881239ec48554d3fda9bc286.tar.gz
Refactor LTOFLAGS
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 599ccfa24338..d1901e4b05f4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=bc-gh
pkgver=6.7.3
-pkgrel=1
+pkgrel=2
pkgdesc="Implementation of dc and POSIX bc with GNU extensions"
arch=('aarch64' 'arm' 'armv6h' 'armv7h' 'i686' 'x86_64')
url="https://github.com/gavinhoward/bc"
@@ -27,11 +27,12 @@ sha256sums=(
)
validpgpkeys=('FF360647C7A7147F27DAAEC1B132F881C306590A')
+_ltoflags='-flto=auto'
+: "${LTOFLAGS:-$_ltoflags}"
+
build() {
cd "bc-$pkgver"
- test -n "$LTOFLAGS" || LTOFLAGS='-flto=auto'
-
env CFLAGS="$CFLAGS -O3" \
PREFIX=/usr ./configure.sh -p GNU -e -G -sbc.banner -sdc.tty_mode
make