summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorThomas Weißschuh2022-10-31 01:38:58 +0100
committerThomas Weißschuh2022-10-31 01:40:18 +0100
commita28d0545461a4169c4128a730c34c68561789376 (patch)
tree55e4b909c013f477230de838eff49cbd4f98e7f4 /PKGBUILD
parent0efcbce6a9e271f2dc24eee00eb26a7193756809 (diff)
downloadaur-a28d0545461a4169c4128a730c34c68561789376.tar.gz
upgpkg: bcachefs-tools 2:23-1
upstream release Add 'bcachefs-tools/' from commit '0efcbce6a9e271f2dc24eee00eb26a7193756809' git-subtree-dir: bcachefs-tools git-subtree-mainline: 7aaa84c1e4c972597e095f3e2e9acd277a995576 git-subtree-split: 0efcbce6a9e271f2dc24eee00eb26a7193756809
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD47
1 files changed, 18 insertions, 29 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 05713a8a2cab..514b83544450 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,40 +1,29 @@
-# Maintainer : Dan Beste <dan.ray.beste@gmail.com>
+# Maintainer: Thomas Weißschuh <thomas t-8ch de>
-pkgname='bcachefs-tools'
-pkgver=r268.b1814f2
+pkgname=bcachefs-tools
+epoch=2
+pkgver=23
pkgrel=1
-pkgdesc='Bcachefs filesystem utilities'
-arch=('i686' 'x86_64')
-url='http://bcachefs.org/'
-license=('unknown')
-makedepends=('git' 'libsodium' 'liburcu' 'libscrypt-git')
-optdepends=('libscrypt: Currently broken with some makeflags')
-provides=("${pkgname}")
-conflicts=("${pkgname}")
-source=('git+https://evilpiepirate.org/git/bcachefs-tools.git')
+pkgdesc="bcachefs filesystem utilities"
+arch=(x86_64)
+url="https://evilpiepirate.org/git/bcachefs-tools.git/"
+license=('GPL2')
+depends=(liburcu libaio util-linux-libs keyutils zstd libsodium)
+checkdepends=(python-pytest)
+source=("git+https://evilpiepirate.org/git/bcachefs-tools.git#tag=v${pkgver}")
sha256sums=('SKIP')
-pkgver() {
- cd "${pkgname}"
-
- printf "r%s.%s" \
- "$(git rev-list --count HEAD)" \
- "$(git rev-parse --short HEAD)"
+prepare() {
+ cd "$pkgname"
+ sed -i -e 's|ROOT_SBINDIR=/sbin|ROOT_SBINDIR=$(PREFIX)/bin|' Makefile
}
build() {
- cd "${pkgname}"
-
- make
+ cd "$pkgname"
+ make PREFIX=/usr $MAKEFLAGS
}
package() {
- cd "${pkgname}"
-
- make \
- DESTDIR="${pkgdir}/usr" \
- ROOT_SBINDIR=/bin \
- install
+ cd "$pkgname"
+ make PREFIX=/usr $MAKEFLAGS DESTDIR="$pkgdir/" install
}
-
-# vim: ts=2 sw=2 et: