summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKyle De'Vir2019-04-10 04:39:50 +1000
committerKyle De'Vir2019-04-10 04:39:50 +1000
commita01954d904e1b9dd15c4bc671f06fa49299a39ef (patch)
tree9f4a2124fadb0be51583d6d0e18745563480f5d4 /PKGBUILD
parent4855850f5faf0677dc6d697d8669b8c018f0f221 (diff)
downloadaur-a01954d904e1b9dd15c4bc671f06fa49299a39ef.tar.gz
Refactor
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD54
1 files changed, 37 insertions, 17 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0094678dd7de..aeed1896804d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,43 +1,63 @@
-# Maintainer: Kyle De'Vir (QuartzDragon) <kyle[dot]devir[at]mykolab[dot]com>
+# Maintainer: Kyle De'Vir (QuartzDragon) <kyle.devir.mykolab.com>
pkgname=bcachefs-tools-git
pkgver=441
pkgrel=1
-pkgdesc="bcachefs filesystem utilities"
-url="https://evilpiepirate.org/git/bcachefs-tools.git/"
+pkgdesc="BCacheFS filesystem utilities"
+url="https://github.com/koverstreet/bcachefs-tools"
arch=("x86_64")
license=("GPL2")
install="${pkgname}.install"
provides=("bcachefs-tools")
-makedepends=("git" "libscrypt" "libsodium" "attr" "libutil-linux" "keyutils" "pkgconf" "zlib" "liburcu" "libaio")
-
-source=("git+https://evilpiepirate.org/git/bcachefs-tools"
- "ad41c2fb76a96f772d75f3b4b7687fcd29aa0574.patch")
-sha512sums=('SKIP'
- '0468db1a0b50fd368c0ded997c027ae87178f53293543151510f9683f3435c949462ee5c5f57fc1b790d304a01f2c9ece1cb893b6afc5f6e285ea39d01a95a24')
+makedepends=(
+ "attr"
+ "git"
+ "keyutils"
+ "libaio"
+ "libscrypt"
+ "libsodium"
+ "liburcu"
+ "libutil-linux"
+ "pkgconf"
+ "zlib"
+)
+
+_reponame="bcachefs-tools"
+_repo_url="https://github.com/koverstreet/${_reponame}"
+
+source=(
+ "git+${_repo_url}"
+ "add-mkinitcpio-hook-for-Arch.patch"
+)
+sha256sums=('SKIP'
+ 'b4d6bc483b417ceaa5c628c686a613e568e64a699288da0388d508a481c710e9')
pkgver() {
- cd bcachefs-tools
+ cd "${_reponame}"
- echo $(git rev-list --count HEAD)
+ echo "$(git rev-list --count HEAD)"
}
prepare() {
- cd bcachefs-tools
- patch -Np1 < ../ad41c2fb76a96f772d75f3b4b7687fcd29aa0574.patch
+ cd "${_reponame}"
+
+ patch -Np1 -i "../add-mkinitcpio-hook-for-Arch.patch"
}
build() {
- cd bcachefs-tools
+ cd "${_reponame}"
make
}
package() {
- cd bcachefs-tools
+ cd "${_reponame}"
make DESTDIR="${pkgdir}" PREFIX="/usr" ROOT_SBINDIR="/usr/bin" INITRAMFS_DIR="/etc/initcpio" install
- install -Dm644 "arch/etc/initcpio/hooks/bcachefs" "${pkgdir}/etc/initcpio/hooks/bcachefs"
- install -Dm644 "arch/etc/initcpio/install/bcachefs" "${pkgdir}/etc/initcpio/install/bcachefs"
+
+ install -Dm644 "arch/etc/initcpio/hooks/bcachefs"
+ "${pkgdir}/etc/initcpio/hooks/bcachefs"
+ install -Dm644 "arch/etc/initcpio/install/bcachefs"
+ "${pkgdir}/etc/initcpio/install/bcachefs"
}