summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJohnathan Jenkins2016-10-04 13:46:54 -0700
committerJohnathan Jenkins2016-10-04 13:46:54 -0700
commit6cbf1a1502248a240c3119f3f576c09fda8239b9 (patch)
tree124bb9959854f0b5c09447e8a1620c2670a9a23f /PKGBUILD
downloadaur-6cbf1a1502248a240c3119f3f576c09fda8239b9.tar.gz
init release
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9603e7cb6cb4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: John Jenkins <twodopeshaggy@gmail.com>
+
+pkgname=bcal
+pkgver=35.68f5bba
+pkgrel=1
+pkgdesc="Byte CALculator. The engineer's utility for storage conversions and calculations."
+arch=("i686" "x86_64")
+url="https://github.com/jarun/bcal"
+license=('GPL3')
+source=(${pkgname}::"git+https://github.com/jarun/${pkgname}.git")
+sha256sums=('SKIP')
+conflicts=('bcal')
+provides=('bcal')
+
+pkgver() {
+ cd "${srcdir}/${pkgname}"
+ echo "$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+}
+
+package() {
+ make -C "${srcdir}/${pkgname}" DESTDIR="${pkgdir}" PREFIX="/usr" install
+}