summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTroy Engel2017-03-13 19:01:34 -0500
committerTroy Engel2017-03-13 19:01:34 -0500
commiteba87eba247349d996dce2523bfe2a6a7cd5e616 (patch)
tree979421e0b3770f19dceeaf8cbe867b462e1a5f31 /PKGBUILD
parent0467e06345072bd29f5c0d6baca3ba5260c19aca (diff)
downloadaur-eba87eba247349d996dce2523bfe2a6a7cd5e616.tar.gz
0.3.0, patch to not include static examples
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 12 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4e4c912e545d..659644c57bc7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgbase=bcc
pkgname=('bcc' 'bcc-tools' 'python-bcc' 'python2-bcc')
-pkgver=0.2.0
+pkgver=0.3.0
pkgrel=1
pkgdesc="BPF Compiler Collection"
arch=('x86_64')
@@ -11,8 +11,17 @@ license=('Apache')
conflicts=('bcc-git')
makedepends=('cmake' 'clang>=3.7.0' 'llvm>=3.7.0' 'flex' 'bison' 'python'
'python2')
-source=("https://github.com/iovisor/${pkgname}/archive/v${pkgver}.tar.gz")
-sha256sums=('8bdea41286dda0605e3e52fc76d345356dc637434935a112e6378e2dcb439a70')
+source=("https://github.com/iovisor/${pkgname}/archive/v${pkgver}.tar.gz"
+ 'cppex-0.3.0.patch')
+sha256sums=('88f54dff96c30c6e7b45f475938eef790b1c9485f794b1ac6791c4e56007f7cc'
+ 'b28a2c5149394fb7402dad92e4c0552644b63dd41394569b966eceb96fc5477e')
+
+prepare() {
+ # the provided CMakeLists.txt compiles the cpp examples with a static copy
+ # of libbcc, ending up with ~282megs used; we'll just install the raw *.cc
+ cd "${srcdir}"
+ patch -p0 < "${srcdir}/cppex-0.3.0.patch"
+}
build() {
# make sure repetitive builds are clean