summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChristian Krause2017-05-14 23:03:03 +0200
committerChristian Krause2017-05-14 23:03:03 +0200
commitc6047918401e94573d8a10061277c125473e86f9 (patch)
treec3c217ef3125434922c38ecd8ac81bc8ce13eeca /PKGBUILD
parent292712615848a243ff84e54e972cb14252c13fb0 (diff)
downloadaur-c6047918401e94573d8a10061277c125473e86f9.tar.gz
bcftools-1.4.1-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 8 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 274884614651..3b311bcd3714 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,14 @@
# Maintainer: Christian Krause ("wookietreiber") <christian.krause@mailbox.org>
pkgname=bcftools
-pkgver=1.4
+pkgver=1.4.1
pkgrel=1
pkgdesc="Reading/writing BCF2/VCF/gVCF files and calling/filtering/summarising SNP and short indel sequence variants"
arch=('i686' 'x86_64')
url="http://samtools.github.io/bcftools/"
license=('GPL')
depends=('gsl' 'htslib')
+optdepends=('python2: needed for some scripts')
source=(https://github.com/samtools/bcftools/releases/download/$pkgver/$pkgname-$pkgver.tar.bz2
makefile-system-htslib.patch)
@@ -17,6 +18,10 @@ prepare() {
# prevent shipped htslib to be used
rm -rf htslib-$pkgver
+ sed -e 's|#!/usr/bin/env python|#!/usr/bin/env python2|' \
+ -e 's|#!/usr/bin/python|#!/usr/bin/env python2|' \
+ -i misc/plot-roh.py misc/guess-ploidy.py
+
# patch Makefile to make it work with a system-provided htslib
patch -i $srcdir/makefile-system-htslib.patch
}
@@ -39,5 +44,5 @@ package() {
make prefix=/usr plugindir=/usr/lib/$pkgname USE_GPL=1 DESTDIR=$pkgdir install
}
-md5sums=('50ccf0a073bd70e99cdb3c8be830416e'
- 'baba7d2fc8947c7ec29ff4498637ea85')
+md5sums=('103729569ca3e265b13d2fed5775016e'
+ '1777e7d3bcfd428de407f62c870904cb')