summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorquest2019-12-06 23:58:09 -0800
committerquest2019-12-06 23:58:09 -0800
commitc8cae479855f411479fb8cb33e34ca38336f014c (patch)
tree226ce208847cb16e28bd878053b44c06353cb07e /PKGBUILD
downloadaur-c8cae479855f411479fb8cb33e34ca38336f014c.tar.gz
Initial commit for bchd 0.15.2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..031c298126c8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Josh Ellithorpe <quest at mac dot com>
+
+pkgname=bchd
+pkgver=0.15.2
+pkgrel=0
+pkgdesc="BCHD is an alternative BCH implementation written in Go."
+arch=('i686' 'x86_64')
+url="http://github.com/gcash/bchd"
+license=('MIT')
+makedepends=('go' 'git')
+options=('!strip' '!emptydirs')
+provides=("s=${pkgver}")
+source=("https://github.com/gcash/${pkgname}/archive/v${pkgver}.tar.gz")
+sha256sums=('9f627d611a732466cc504aae7b54830aa5f58c6421db66d914a8d68b471bd17b')
+
+build() {
+ mkdir -p "${srcdir}/go/src/github.com/gcash"
+ export GOPATH="${srcdir}/go"
+ export GOBIN="$GOPATH/bin"
+
+ mv "$pkgname-$pkgver" "$GOPATH/src/github.com/gcash/bchd"
+ cd "$GOPATH/src/github.com/gcash/bchd"
+
+ make
+}
+
+package() {
+ cd "${srcdir}/go/src/github.com/gcash/bchd"
+
+ install -Dm 775 "bchd" \
+ "${pkgdir}/usr/bin/${pkgname}"
+ install -Dm 775 "bchctl" \
+ "${pkgdir}/usr/bin/bchctl"
+ install -Dm 644 "LICENSE" \
+ "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}