summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKarsten Pufahl2019-11-26 11:32:33 +0100
committerKarsten Pufahl2019-11-26 11:32:33 +0100
commit6d02d9271dd1906a29d109a6d9cb201fa45d4934 (patch)
treef343a1bd0fb1c7efc7d4bacc3028b005eb8e481a /PKGBUILD
downloadaur-bcn3dcura-git.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD58
1 files changed, 58 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7fc9fe5d93da
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,58 @@
+# Maintainer: Adam Goldsmith <contact@adamgoldsmith.name>
+
+pkgname=bcn3dcura-git
+pkgver=2.1.5
+pkgrel=1
+pkgdesc="3D printer / slicing GUI forked from Cura and built on top of the Uranium framework, customized for the BCN3D machines."
+arch=('any')
+license=('GPL3')
+url="https://github.com/BCN3D/Cura"
+provides=('cura' 'bcn3dcura')
+conflicts=('cura' 'bcn3dcura')
+depends=('python'
+ 'python-pyqt5'
+ 'python-numpy'
+ 'python-protobuf'
+ 'qt5-graphicaleffects'
+ 'qt5-quickcontrols'
+ 'qt5-quickcontrols2'
+ 'libarcus-git'
+ 'libsavitar'
+ 'bcn3duranium-git'
+ 'bcn3dcuraengine-git')
+makedepends=('git' 'cmake')
+optdepends=('python-zeroconf: Detecting mDNS printers'
+ 'cura-binary-data-git: Firmwares and translations'
+ 'python-pyserial: USB printing')
+source=('git+https://github.com/BCN3D/Cura.git'
+ 'git+https://github.com/BCN3D/CuraResources.git'
+ 'bcn3dcura.patch')
+md5sums=('SKIP'
+ 'SKIP'
+ '82ab7bf90b0c3529a571bbb9e8f912ae')
+
+prepare() {
+ cd $srcdir
+ patch --forward --strip=1 --input="${srcdir}/bcn3dcura.patch"
+}
+
+pkgver() {
+ cd Cura
+ git describe --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ mkdir -p Cura/build
+ cd Cura/build
+ cmake -DCMAKE_INSTALL_PREFIX=/usr -DURANIUM_SCRIPTS_DIR=/usr/share/uranium/scripts ..
+ make
+}
+
+package() {
+ cd "$srcdir/Cura/build"
+ make DESTDIR="$pkgdir/" install
+ cd "$srcdir/CuraResources"
+ cp -r ./. "$pkgdir/usr/share/cura/resources"
+}
+
+# vim:set ts=2 sw=2 et: