summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKohei Suzuki2019-08-14 21:47:28 +0900
committerKohei Suzuki2019-08-17 03:39:52 +0900
commit66e0f0964b7dca027030ec10b7ccee07563c0e73 (patch)
treef56db09b97dffc41e15ca58f2d295dd2ad73185e /PKGBUILD
parenta9f7a58db17da5df1a1c9dae9696290170f19e02 (diff)
downloadaur-66e0f0964b7dca027030ec10b7ccee07563c0e73.tar.gz
Update bdash to v1.5.7
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 8 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9a20e30c30c4..c54f0fb1aec6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Maintainer: Kohei Suzuki <eagletmt@gmail.com>
pkgname=bdash
-pkgver=1.5.6
+pkgver=1.5.7
pkgrel=1
pkgdesc='Simple business intelligence application'
arch=('x86_64')
url='https://github.com/bdash-app/bdash'
license=('MIT')
-options=('!strip')
-makedepends=('node-gyp' 'python2' 'python' 'yarn')
+depends=('gtk3' 'nss' 'libxss' 'gconf')
+makedepends=('node-gyp' 'python' 'yarn')
source=("$pkgname-$pkgver.tar.gz::https://github.com/bdash-app/bdash/archive/v$pkgver.tar.gz")
build() {
@@ -15,14 +15,15 @@ build() {
yarn install --no-progress
yarn run webpack --env.BUILD_ENV=production
- yarn run electron-builder build --linux AppImage --x64
+ yarn run electron-builder build --linux dir --x64
}
package() {
- mkdir -p "$pkgdir/usr/bin"
- mv "$pkgname-$pkgver/dist/production/Bdash-$pkgver-x86_64.AppImage" "$pkgdir/usr/bin/bdash"
+ mkdir -p "$pkgdir/opt" "$pkgdir/usr/bin"
+ mv "$pkgname-$pkgver/dist/production/linux-unpacked" "$pkgdir/opt/bdash"
+ ln -s /opt/bdash/bdash "$pkgdir/usr/bin/bdash"
}
# vim: set ft=sh:
-sha512sums=('1d01d3979d34958251b56836254ed8044e8b3ec870e926335bd1d9ef661d8ed34c56a9ce711d6601343a969c3805fcccd01ca245b978d137f4cf83dff0263268')
+sha512sums=('008e1a9081312bbc7ddbff4a966861f49673d050aff7a0ea75fc1a9cfb207de90d876ab3b64af64378237725be95fa3c0b09fc3a0984a6a10738e8e6cf368edc')