summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRaymond W. Ko2016-02-24 13:07:51 -0500
committerRaymond W. Ko2016-02-24 13:07:51 -0500
commit4524a2483574929db1e0e0ba84273598c7933277 (patch)
treef9098b3e56357f1621cca1ac07dc1ad8ad12f9fc /PKGBUILD
parent5fdcf06633ce1968e73f1ddc33f966fece62dd5b (diff)
downloadaur-4524a2483574929db1e0e0ba84273598c7933277.tar.gz
add python makedep, compress fonts to pcf.gz
base on suggestions by lucy, adding Python 3 as a make dependency. Also the fonts were getting kind of big, so I switched from distributing them as *.bdf to *.pcf.gz
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 5 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f9380c3f2618..623e4f853478 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,14 @@
pkgname=bdf-tewi-git
_gitname=tewi-font
-pkgver=0.281.dab6e6b
+pkgver=0.290.9841a18
pkgrel=1
pkgdesc='Bitmap font'
arch=('any')
url="https://github.com/lucy/tewi-font"
license=('MIT')
depends=('xorg-fonts-encodings' 'xorg-font-utils')
-makedepends=('git')
+makedepends=('git python make')
install="$pkgname.install"
source=('git+https://github.com/lucy/tewi-font.git')
sha256sums=('SKIP')
@@ -21,11 +21,9 @@ pkgver() {
package() {
cd "$_gitname"
+ make var
+ make all
install -T -Dm644 "LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
install -d -m755 "$pkgdir/usr/share/fonts/misc/"
- install -m644 -t "$pkgdir/usr/share/fonts/misc/" \
- "tewi-bold-11.bdf" "tewi-medium-11.bdf" \
- "tewifw-bold-11.bdf" "tewifw-medium-11.bdf" \
- "variant/tewi2a-bold-11.bdf" "variant/tewi2a-medium-11.bdf" \
- "variant/tewii-bold-11.bdf" "variant/tewii-medium-11.bdf"
+ install -m644 -t "$pkgdir/usr/share/fonts/misc/" out/*.pcf.gz
}