summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorrnndxb wxcy2015-06-10 20:07:04 -0400
committerrnndxb wxcy2015-06-10 20:07:04 -0400
commite99f3d9defbfb0ee9272abdad3fd6b0ba68a37a2 (patch)
tree1fcf8dd60a6ce394c8cd20826e60898cd1366024 /PKGBUILD
downloadaur-e99f3d9defbfb0ee9272abdad3fd6b0ba68a37a2.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..02c9075d5719
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: ntwk <rnndxb@gmail.com>
+
+pkgname=bdfresize
+pkgver=1.5
+pkgrel=1
+epoch=
+pkgdesc="A command to scale fonts in Bitmap Distribution Format"
+arch=('i686' 'x86_64')
+url="http://openlab.ring.gr.jp/efont"
+license=('GPL')
+source=("$url/dist/tools/$pkgname/$pkgname-$pkgver.tar.gz"
+ "010_ftbfs-gcc4.patch"
+ "020_minus-sign.patch")
+sha256sums=('440cfc0620a0237e46352c14a0774caa3f3059759b0a20defefc94e8490897a6'
+ 'b2bfe278b5719ce8b946e20372d4a8d4c6630eeb74c0212c1c454911676ecbd9'
+ 'ee1032245a87e6821d83cfff5230585ba707f307263a56b20f0f3672686832c1')
+
+prepare() {
+ cd "$pkgname-$pkgver"
+ patch -p1 -i "../010_ftbfs-gcc4.patch"
+ patch -p1 -i "../020_minus-sign.patch"
+ autoreconf -vfi
+}
+
+build() {
+ cd "$pkgname-$pkgver"
+ ./configure --prefix=/usr
+ make
+}
+
+check() {
+ cd "$pkgname-$pkgver"
+ make -k check
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+}