summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSaulius Lukauskas2015-08-05 11:47:08 +0100
committerSaulius Lukauskas2015-08-05 11:47:08 +0100
commit8222696acbba24707ebf34a4bcd2a5ebc678e1e2 (patch)
tree88cc73e50357d990ff7d0a2c0ec204a419a21010 /PKGBUILD
downloadaur-8222696acbba24707ebf34a4bcd2a5ebc678e1e2.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c5c0ae6a7ba7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Sauliusl <luksaulius[at]gmail[dot]com>
+pkgname=beads
+pkgver=1.1
+pkgrel=1
+pkgdesc="Bias Elimination Algorithm for Deep Sequencing."
+url="http://beads.sourceforge.net/"
+arch=('x86_64')
+license=('unknown')
+depends=('python2' 'java-environment')
+optdepends=()
+makedepends=('python2')
+conflicts=()
+replaces=()
+backup=()
+install=()
+source=("http://downloads.sourceforge.net/project/beads/BEADS-${pkgver}.tar.gz"
+ "beads.sh")
+sha1sums=('f83587d3b8c7b1eb619d81e17499e8f8fdae3138'
+ 'b30b472b1ff087eb3c015f00bd4619b346421cf5')
+package() {
+ cd "${srcdir}/BEADS-${pkgver}"
+ python2 setup.py install --prefix=${pkgdir}/usr
+
+ # Rename the python file to have .py extension
+ mv ${pkgdir}/usr/bin/beads ${pkgdir}/usr/bin/beads.py
+ # install script that presets the classpath beforehand in place of it
+ install -Dm755 ${srcdir}/beads.sh ${pkgdir}/usr/bin/beads
+
+ # Install the java classes
+ install -d ${pkgdir}/usr/share/java/${pkgname}
+ install -Dm0644 BEADSjava.jar ${pkgdir}/usr/share/java/${pkgname}
+}
+
+# vim:set ts=2 sw=2 et: \ No newline at end of file