summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPatrick Northon2021-03-24 22:59:25 -0400
committerPatrick Northon2021-03-24 22:59:25 -0400
commite56ff7ab0872066ddb7e69885ab1b54d4cde6dcb (patch)
treebe93f8929cb57b3d9ae30b6554d5de6f053d2761 /PKGBUILD
downloadaur-e56ff7ab0872066ddb7e69885ab1b54d4cde6dcb.tar.gz
Initial commit.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c978251a8157
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Patrick Northon <northon_patrick3@yahoo.ca>
+
+pkgname=beakerlib
+pkgver=1.26
+pkgrel=1
+pkgdesc="BeakerLib is a shell-level integration testing library, providing convenience functions which simplify writing, running and analysis of integration and blackbox tests."
+arch=('i686' 'x86_64')
+url="https://github.com/beakerlib/beakerlib"
+license=('GPL2')
+depends=()
+makedepends=()
+source=("https://github.com/beakerlib/beakerlib/archive/refs/tags/${pkgver}.tar.gz")
+sha256sums=('ca16f5791f5e1212e97ad710a79cb5b43710efb1989450ab806cbab49c8b50a6')
+
+_srcdir="${pkgname}-${pkgver}"
+
+build() {
+ cd "${_srcdir}"
+ make
+}
+
+package() {
+ cd "${_srcdir}"
+ make DD="${pkgdir}" install
+}