summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSiôn Le Roux2015-11-01 23:55:47 +0100
committerSiôn Le Roux2015-11-01 23:55:47 +0100
commit2f94c32e28f36328e24f0f782f75fae188cd9973 (patch)
tree13ddccfa3e09c53cf1977303de14d2b1d85a6954 /PKGBUILD
downloadaur-beamercolorthemesolarized.tar.gz
Initial commit: working PKGBUILD for beamercolorthemesolarized
* Uses git revision info for version number * Installs beamercolorthemesolarized.sty amongst the other beamer colour schemes * Runs texhash on install/uninstall to refresh TeX DB * .SRCINFO contains hard-coded version because AUR4 is strict
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..543a3a578c54
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Siôn le Roux <sinisterstuf@gmail.com>
+# Please submit issues, patches or merge-requests at:
+# https://github.com/sinisterstuf/PKGBUILD-beamercolorthemesolarized
+
+pkgname=beamercolorthemesolarized
+pkgver=r43.3d95d47 # this is generated by pkgver() below
+pkgrel=1
+pkgdesc="Beamer color theme using the Solarized palette"
+arch=('any')
+url="https://github.com/jrnold/beamercolorthemesolarized"
+license=('GPL')
+depends=('texlive-core')
+makedepends=('git')
+source=('git+https://github.com/jrnold/beamercolorthemesolarized.git')
+install=$pkgname.install
+md5sums=('SKIP')
+
+pkgver() {
+ # Git, no tags available
+ cd "$srcdir/${pkgname%-git}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ local latexdist='usr/share/texmf-dist/tex/latex/beamer/themes/color'
+ local themefile=${pkgname%-git}/${pkgname%-git}.sty
+
+ install -Dm644 -t$pkgdir/$latexdist $srcdir/$themefile
+}
+
+# vim:set ts=2 sw=2 et: