summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMattias Giese2021-08-05 20:29:46 +0200
committerMattias Giese2021-08-05 20:29:46 +0200
commit65d931115ede80f9aae80b0c063f1dfc427fade8 (patch)
treeb4f8662c0117bf4d7a40390845f5d8954dcbf416 /PKGBUILD
downloadaur-65d931115ede80f9aae80b0c063f1dfc427fade8.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD58
1 files changed, 58 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..42523ff983b6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,58 @@
+# Maintainer: Mattias Giese <mattias.giese@posteo.net>
+pkgname=beammp-server
+_pkgname=BeamMP-Server
+pkgver=v2.2.0.r0.3d0d5e9
+_pkgver=2.2.0
+pkgrel=1
+pkgdesc="Server for BeamMP, providing multiplayer support for the driving simulator beamng.drive"
+arch=(x86_64)
+url="https://beammp.com/"
+license=('proprietary')
+groups=()
+depends=('lua53' 'zlib' 'openssl' 'rapidjson' 'boost' 'websocketpp')
+makedepends=('git' 'gcc' 'make' 'cmake') # 'bzr', 'git', 'mercurial' or 'subversion'
+replaces=()
+backup=()
+options=()
+install=
+source=("git+https://github.com/BeamMP/${_pkgname}.git#tag=v${_pkgver}" "beammp.sysusers" "beammp.service")
+noextract=()
+md5sums=('SKIP' 'SKIP' 'SKIP')
+
+# Please refer to the 'USING VCS SOURCES' section of the PKGBUILD man page for
+# a description of each element in the source array.
+
+pkgver() {
+ cd "$srcdir/${_pkgname}"
+
+# The examples below are not absolute and need to be adapted to each repo. The
+# primary goal is to generate version numbers that will increase according to
+# pacman's version comparisons with later commits to the repo. The format
+# VERSION='VER_NUM.rREV_NUM.HASH', or a relevant subset in case VER_NUM or HASH
+# are not available, is recommended.
+
+# Git, tags available
+ printf "%s" "$(git describe --long | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
+}
+
+prepare() {
+ cd "$srcdir/${_pkgname}"
+ git submodule update --init
+}
+
+build() {
+ cd "$srcdir/${_pkgname}"
+ cmake .
+ make
+}
+
+check() {
+ true
+}
+
+package() {
+ install -D beammp.sysusers "${pkgdir}/usr/lib/sysusers.d/beammp.conf"
+ install -D beammp.service "${pkgdir}/usr/lib/systemd/system/beammp.service"
+ cd "$srcdir/${_pkgname}"
+ install -D BeamMP-Server "${pkgdir}/opt/beammp/beammp-server"
+}