summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMax Ferrer2019-01-04 16:25:21 -0300
committerMax Ferrer2019-01-04 16:25:21 -0300
commit2a078101e46356c6fd8358312146a56d68bc4b2a (patch)
tree40c568ad86754b40ebd31113a74bc9c2da3a2c7a /PKGBUILD
downloadaur-2a078101e46356c6fd8358312146a56d68bc4b2a.tar.gz
Creating beamwallet-bin package
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8508dac9cd6f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Max Ferrer <maxi.fg13 at gmail dot com>
+
+pkgname="beamwallet-bin"
+pkgver=1.0.3976
+pkgrel=1
+pkgdesc="Scalable confidential cryptocurrency"
+arch=("x86_64")
+url="https://www.beam.mw"
+license=("custom:beam")
+makedepends=("binutils" "tar")
+source=("Beam-Wallet-1.0.3976.deb::https://builds.beam.mw/mainnet/2019.01.03/Release/linux")
+sha256sums=("ac5fce080df0a21ede3d13bd5a8366374be969ceeab6bb685a224385f1b14adc")
+
+prepare() {
+ tar xf control.tar.gz
+}
+
+pkgver() {
+ cat control | head -n 2 | tail -n 1 | cut -d' ' -f 2
+}
+
+package() {
+ tar xf data.tar.gz -C "${pkgdir}/"
+ _desktop_file=${pkgdir}/usr/share/applications/beam.desktop
+}
+
+# vim:set ts=2 sw=2 et: