summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAdrian Perez de Castro2019-01-07 12:21:40 +0200
committerAdrian Perez de Castro2019-01-07 12:21:40 +0200
commit364cca924646569eca2883e2b3663f7f26da7fae (patch)
tree19609aee6ffcf145ea499d9407a949a3baae4175 /PKGBUILD
parentee4d90b1bdd50bc3afcb64e01fdf4efee1af90b0 (diff)
downloadaur-beancount-hg.tar.gz
Update pkgver() and provides as suggested to include tagged version
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f6b3f22fe328..5bee7288054a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Adrian Perez <aperez@igalia.com>
pkgname='beancount-hg'
pkgdesc='Double-Entry Accounting from Text Input'
-pkgver=r4435.17e54014214b
+pkgver=2.2.0.r2.9d7552d320a3
pkgrel=1
arch=('i686' 'x86_64')
url="http://furius.ca/beancount/"
@@ -13,12 +13,12 @@ depends=('python>=3.5' 'mpdecimal' 'python-ply' 'python-dateutil'
'python-bottle' 'python-lxml' 'python-google-api-python-client')
makedepends=('mercurial' 'python-nose' 'make')
replaces=('ledgerhub-hg')
-provides=('ledgerhub-hg' 'beancount')
+provides=('ledgerhub-hg' "beancount=${pkgver%%.r*}")
conflicts=('beancount')
-pkgver () {
- cd "${pkgname}"
- printf "r%s.%s" "$(hg identify -n)" "$(hg identify -i)"
+pkgver() {
+ cd "${pkgname}"
+ hg log -r . --template '{latesttag}-{latesttagdistance}-{node|short}' | sed 's/^\([^-]*\)-\([^-]*\)-/\1.r\2./'
}
# TODO: Tests are failing at the moment, needs investigating.