summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorZhuoyun Wei2025-04-13 03:31:56 -0700
committerZhuoyun Wei2025-04-13 03:31:56 -0700
commitbd743f5aa87860c2d7b2d09e3c7b82b1cdd244ff (patch)
treec59052625496fb39e4c3202085ebd7cc02c2f43b /PKGBUILD
parent1158642ea8c3c0b5fc97f8c29422885f204a6562 (diff)
downloadaur-bd743f5aa87860c2d7b2d09e3c7b82b1cdd244ff.tar.gz
0.2.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 4 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 16829a67328f..a8d9c8413a17 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,21 +2,17 @@
pkgname=beanquery
pkgdesc='A customizable light-weight SQL query tool that works on tabular data, including Beancount'
-pkgver=0.1.0
-pkgrel=5
+pkgver=0.2.0
+pkgrel=1
arch=("any")
url="https://github.com/beancount/beanquery"
license=('GPL')
source=("https://files.pythonhosted.org/packages/source/${pkgname::1}/${pkgname}/${pkgname}-${pkgver}.tar.gz")
-b2sums=('740590b554b484b73fabfdacd60e9d17e64628230d9949b131645b53adda5c3050739f9df694d251b67b3d611ede83604da10f6a616648795aec6d430dee99ae')
+b2sums=('2b9c389fcafe5186beba9c2b0cb1178fa78e7cb415c0f9e72c23f88ef947f8bfe8971f27fc87c4675d85ff965c8d6d5181cf23f8607f298e58a0354841a9b6d8')
# NOTE: The Python package technically does not require beancount 3.x but it
# provides /usr/bin/bean-query which conflicts with beancount 2.x and so we
# require beancount 3.x here.
-# NOTE: The Python package requires 'tatsu >= 5.7.4, < 5.8.0', and the only
-# version meets the requirement is 5.7.4 released in 2022. You can build it
-# with this PKGBUILD:
-# https://gist.github.com/wzyboy/a5acef9bc8e9bfd74f07696b21551c65
-depends=("python" "beancount>=3" "python-click" "python-tatsu=5.7.4")
+depends=("python" "beancount>=3" "python-click" "python-tatsu-lts")
makedepends=("python-build" "python-installer" "python-wheel" "python-setuptools")
build() {