summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDrobot Viktor2019-09-25 11:40:59 +0300
committerDrobot Viktor2019-09-25 11:40:59 +0300
commit0597924273dc8932b01aa73109568ba6a217bf4e (patch)
treedb34618f51ea191a85c32ce95beecdeb7b1987bd /PKGBUILD
parent38d2788e2fd4e762285d8d77391ce8927c2658a1 (diff)
downloadaur-0597924273dc8932b01aa73109568ba6a217bf4e.tar.gz
Fixed PKGBUILD
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD38
1 files changed, 14 insertions, 24 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ba306331942f..8dca1859bedc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,10 @@
-# Maintainer: Moritz Lipp <mlq@pwmt.org>
+# Maintainer: Viktor Drobot (aka dviktor) linux776 [at] gmail [dot] com
+# Contributor: Moritz Lipp <mlq@pwmt.org>
pkgname=bear-git
-pkgver=1.4.48.g3e0e1ad
+pkgver=r492.c3c3537
pkgrel=1
-pkgdesc="tool to generate compilation database for clang tooling"
+pkgdesc="Tool to generate compilation database for clang tooling"
arch=('i686' 'x86_64')
url="https://github.com/rizsotto/Bear"
license=('GPL3')
@@ -11,37 +12,26 @@ makedepends=('git' 'cmake' 'make' 'pkg-config')
depends=('python>=2.7')
conflicts=('bear')
provides=('bear')
-source=('bear::git+https://github.com/rizsotto/Bear.git')
+source=("${pkgname}::git+https://github.com/rizsotto/Bear.git")
sha1sums=('SKIP')
-_gitname=bear
+
+pkgver() {
+ cd "${pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
build() {
- cd "$srcdir/$_gitname"
+ cd "${pkgname}"
+
cmake \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_SYSCONFDIR=/etc \
.
- make all
-}
-check() {
- cd "$srcdir/$_gitname"
- PATH=/usr/bin:$PATH make -k check
+ make all
}
package() {
- cd "$srcdir/$_gitname"
+ cd "${pkgname}"
make DESTDIR="$pkgdir/" install
-
- if [ $CARCH = "x86_64" ]; then
- mv $pkgdir/usr/lib64 $pkgdir/usr/lib
- fi
-}
-
-pkgver() {
- cd "$_gitname"
- local ver="$(git describe --long)"
- printf "%s" "${ver//-/.}"
}
-
-# vim:set ts=2 sw=2 et: