summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorlilydjwg2015-07-25 12:39:43 +0800
committerlilydjwg2015-07-25 12:39:43 +0800
commitf09415bcf6befcd7cb13e475a5873d11e1d2e320 (patch)
tree8bcccb4efb365f51309ed05771b93b1954d4967d /PKGBUILD
downloadaur-f09415bcf6befcd7cb13e475a5873d11e1d2e320.tar.gz
import for AUR3
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0ac34aeaf0b9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+pkgname=beautifuldnsd
+pkgver=0.4
+pkgrel=1
+pkgdesc="Quick and clean DNS proxy, especially useful for users with poor ISPs"
+arch=('any')
+url=https://github.com/programmervy/beautifuldnsd
+license=("public domain")
+depends=('python>=3.4' 'python-dnslib' 'python-yaml')
+optdepends=(
+ 'dnsmasq: DNS cache'
+ 'python-pygeoip: China only DNS configuration'
+ 'geoip-database: provides a database for geoip lookups'
+)
+backup=("etc/${pkgname}.yaml")
+install=beautifuldnsd.install
+source=(${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz)
+md5sums=('f750c7df394256816c22636d836fbbd7')
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ install -D -m644 systemd/beautifuldnsd.service "${pkgdir}/usr/lib/systemd/system/${pkgname}.service"
+ install -D -m644 systemd/tmpfiles.conf "${pkgdir}/usr/lib/tmpfiles.d/${pkgname}.conf"
+ install -D -m644 beautifuldnsd.yaml "${pkgdir}/etc/${pkgname}.yaml"
+ install -D -m755 beautifuldnsd "${pkgdir}/usr/bin/${pkgname}"
+}
+