summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorwordofglass2016-03-19 13:13:28 +0100
committerwordofglass2016-03-19 13:13:28 +0100
commit069acced1f45793894792c8c8b7eb0c875332e0b (patch)
treebbb44688e9136faaab9059ee055278b7a712c647 /PKGBUILD
downloadaur-069acced1f45793894792c8c8b7eb0c875332e0b.tar.gz
Initial PGKBUILD, .SRCINFO
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..85ed86740714
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: wordofglass <wordofglass@users.noreply.github.com>
+
+pkgname=beets-copyartifacts-git
+pkgver=v0.1.2.r24.dac4a16
+pkgrel=1
+pkgdesc="A beets plugin that moves non-music files during the import process."
+arch=('any')
+url="https://github.com/sbarakat/${pkgname%-git}"
+license=('MIT')
+depends=('python2' 'beets')
+makedepends=('git')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=("git+${url}.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ printf "%s" "$(git describe --long | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
+}
+
+package() {
+ cd "$srcdir/${pkgname%-git}"
+ python2 setup.py install --root="$pkgdir/" --optimize=1
+ install -Dm644 MIT-LICENSE.txt "$pkgdir/usr/share/licenses/${pkgname%-git}/LICENSE"
+ install -Dm644 README.rst "$pkgdir/usr/share/doc/${pkgname%-git}/README.rst"
+}
+
+# vim: set et sw=4 ts=4 :