summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGuillaume Horel2024-01-02 14:39:44 -0500
committerGuillaume Horel2024-01-02 14:39:44 -0500
commit10a71c80919036f1642b3a3bd7b2ae8b579e05de (patch)
treea6a4267fd5b0aac2a1df0b0d824bfd23a9068a38 /PKGBUILD
parent726f794cfe35a5e0a2ce03b2614916fcea3effe3 (diff)
downloadaur-belr.tar.gz
bump to 5.3.4
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 71dafefdf831..c402abe4cb3d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Guillaume Horel <guillaume.horel@gmail.com>
pkgname=belr
-pkgver=5.2.73
+pkgver=5.3.4
pkgrel=1
pkgdesc="A library for working with vCards"
arch=('x86_64')
@@ -9,17 +9,17 @@ url="http://www.linphone.org/"
license=('GPL')
depends=("bctoolbox>=$pkgver")
makedepends=('cmake')
-source=("belr-$pkgver.tar.gz::https://github.com/BelledonneCommunications/belr/archive/$pkgver.tar.gz")
-sha256sums=('5e9933c874dfb4a170295ddfc657b484d7dea5071e4be2fe5b8c51993bda2c51')
+source=("belr-$pkgver.tar.gz::https://github.com/BelledonneCommunications/belr/archive/refs/tags/$pkgver.tar.gz")
+sha256sums=('fc73ffa7edd48dfab8ea5b68a3a00e9ed1ccc68edafa16c9549469bed1c712d1')
build() {
cmake -B build $pkgname-$pkgver \
-DCMAKE_PREFIX_PATH="/usr" \
-DCMAKE_INSTALL_PREFIX="/usr" \
- -DENABLE_STATIC=NO \
+ -DBUILD_SHARED_LIBS=YES \
-DENABLE_TOOLS=NO \
-DCMAKE_SKIP_INSTALL_RPATH=ON \
- -DENABLE_TESTS=NO \
+ -DENABLE_UNIT_TESTS=NO \
-Wno-dev
make -C build
}