summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorsamogot2017-04-24 14:09:24 +0300
committersamogot2017-04-24 14:09:24 +0300
commit0fcd0c9ab2dfff5d35c35903ac919c3e5609aebc (patch)
tree0b5fdc73be582c1278584502894a15263da27882 /PKGBUILD
parent1b9b032ece086f338a723e1d28e98fefbb8e7c1c (diff)
downloadaur-0fcd0c9ab2dfff5d35c35903ac919c3e5609aebc.tar.gz
track git master branch
install into any of installed discord packages (normal, ptb, canary)
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 11 insertions, 18 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b53af5b84d7e..545f5c744898 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,37 +1,30 @@
-# Maintainer: Ilya Trukhanov <lahvuun@gmail.com>
-#
-# This package is based on discorddownloader by simonizor
-# http://www.simonizor.gq/discorddownloader.html
-
-pkgname=betterdiscord
-pkgver=0.2.82
+pkgname=betterdiscord-git
+pkgver=0.2.82.r281.gb92989a
pkgrel=1
-pkgdesc='Discord extension that introduces new features like BTTV emotes and plugin support.'
+pkgdesc='Discord extension that introduces new features like BTTV emotes and plugin support. Git master branch'
arch=('any')
url='https://betterdiscord.net/home/'
license=('MIT')
depends=('discord')
-makedepends=('asar')
+makedepends=('git' 'asar')
install='BetterDiscord.install'
-source=('git+https://github.com/Jiiks/BetterDiscordApp.git#commit=0f2812bc10b3c9695ddf2e28b65bbfe1ae4d1ce7' LICENSE)
+source=("${pkgname%-git}::git+https://github.com/Jiiks/BetterDiscordApp.git" LICENSE)
md5sums=('SKIP'
'8414480728c5dc0d4ca9a93cfaf67acb')
+pkgver() {
+ cd "${srcdir}/${pkgname%-git}"
+ git describe --long --tags | sed 's/-/.r/;s/-/./'
+}
+
package() {
install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
# Get rid of git files.
- mkdir -p "package"
- cp -rf "./BetterDiscordApp/" "./package/"
- cd "./package/BetterDiscordApp/"
+ cd "${srcdir}/${pkgname%-git}"
rm -rf ".git"
rm "./.gitignore"
install -d "${pkgdir}/usr/lib/${pkgname}/"
cp -a "./." "${pkgdir}/usr/lib/${pkgname}"
- mv "${pkgdir}/usr/lib/${pkgname}/lib/Utils.js" "${pkgdir}/usr/lib/${pkgname}/lib/utils.js"
-
- # Patch BetterDiscord files.
- sed -i "s/'\/var\/local'/process.env.HOME + '\/.config'/g" "${pkgdir}/usr/lib/${pkgname}/lib/BetterDiscord.js"
- sed -i "s/bdstorage/bdStorage/g" "${pkgdir}/usr/lib/${pkgname}/lib/BetterDiscord.js"
}