summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSandy Carter2022-11-20 16:18:14 -0500
committerSandy Carter2022-11-20 16:18:14 -0500
commite4f4a5d5116bc764f759682f15406f4beca74a05 (patch)
tree4a82d015922f20691422dec8c24bae3c31445e9c /PKGBUILD
parenta95f33dd48c811fd1a0d736b2ae817b9dad83289 (diff)
downloadaur-e4f4a5d5116bc764f759682f15406f4beca74a05.tar.gz
fix file type submodule after git update
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 6 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 67ff194d5ea3..75b82253ddd4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Sandy Carter <bwrsandman+aur@gmail.com>
pkgname=bgfx-cmake-git
-pkgver=1.115.8109.a7ac0aa
+pkgver=1.118.8374.52feec4
pkgrel=1
pkgdesc="Cross-platform, graphics API agnostic, \"Bring Your Own Engine/Framework\" style rendering library. (With CMake build scripts)"
arch=('x86_64')
@@ -42,7 +42,11 @@ prepare() {
git config --file=.gitmodules submodule.bimg.url $srcdir/bimg
git config --file=.gitmodules submodule.bgfx.url $srcdir/bgfx
git submodule sync
- git submodule update --init
+ # From git 2.38.1-1, "git submodule" in PKGBUILD does not work
+ # unless we change the git config "protocol.file.allow" [1,2].
+ # [1] https://bugs.archlinux.org/task/76255
+ # [2] https://bbs.archlinux.org/viewtopic.php?pid=2063104#p2063104
+ git -c protocol.file.allow=always submodule update --init
# prepend bgfx to bin names to avoid naming conflicts
for BIN in geometryc geometryv shaderc texturec texturev