summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPaul Clark2020-12-26 13:29:08 +0000
committerPaul Clark2020-12-26 13:29:08 +0000
commite0608e64ddcaa4aae5133997259cc6d71ca04ac4 (patch)
treeb929005413c3d470fd66baba8bb7b0e025a2f0ab /PKGBUILD
parente531e840fd5d681dc6832c79d7bcefd03df5bf25 (diff)
downloadaur-e0608e64ddcaa4aae5133997259cc6d71ca04ac4.tar.gz
Version 4.31
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 9 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6d12d42e5e04..26425e127268 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,28 @@
# Maintainer: Paul Clark <paul500clark at gmail dot com>
# Contributor: David Koenig <koenigdmj@gmail.com>
pkgname=bible-kjv
-pkgver=4.30
+pkgver=4.31
pkgrel=1
pkgdesc="King James Bible, Concordance, and Command-Line Viewer"
-arch=(i686 x86_64)
+arch=(x86_64)
url="http://www.debian.org/"
license=('GPL')
-depends=('glibc')
+depends=('readline')
makedepends=('perl')
source=(http://ftp.debian.org/debian/pool/main/b/${pkgname}/${pkgname}_${pkgver}.tar.gz
makefile.patch)
-md5sums=('0fd7710b7d5c60543756701474cc9d01'
- 'e234e246b418fbd75a3855e321775a9e')
+sha256sums=('80a325d01b7e42a36b8c3673ca96a4373fc3280e9fa96cb7ca5e5c24bca0c3ac'
+ '91bb9de66b17d67b72f5de57098928aa897ba62a77b5ddcf2695e74c0a97d572')
package () {
patch -p1 < makefile.patch
- cd $pkgname
+ cd work
+
+ export MAKEFLAGS="-j1"
# upstream ebuild wants "make all", not just "make"
- make DEST="/usr" DESTLIB="/usr/share/$pkgname" MAKEFLAGS="-j1" all || return 1
+ make DEST="/usr" DESTLIB="/usr/share/$pkgname" all || return 1
make DEST="$pkgdir/usr" DESTLIB="$pkgdir/usr/share/$pkgname" install
# copy for user convenience