summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorEmmanuel Gil Peyrot2020-09-23 12:18:40 +0200
committerEmmanuel Gil Peyrot2020-09-23 12:18:59 +0200
commitc0a57c426cb46e03e755b934f576fb46c6898d1b (patch)
treec373198ba5fbc0d43c6fe4cb48feac05d4112b4a /PKGBUILD
parentd087b27a9f65aa177e151154ace8734f4fec271c (diff)
downloadaur-biboumi.tar.gz
Bump to 9.0 release, copying aur/biboumi-git.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 14 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e37ff360bbe7..ae1c8e4d2e22 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,19 @@
# Maintainer: Emmanuel Gil Peyrot <linkmauve@linkmauve.fr>
pkgname=biboumi
-pkgver=8.5
-pkgrel=2
+pkgver=9.0
+pkgrel=1
pkgdesc="XMPP gateway to IRC"
-arch=('i686' 'x86_64' 'armv7h' 'aarch64')
+arch=('x86_64' 'armv7h' 'aarch64')
url="https://biboumi.louiz.org/"
license=('ZLIB')
depends=('expat' 'libidn' 'udns' 'botan' 'sqlite' 'postgresql-libs')
-makedepends=('cmake' 'pandoc' 'catch2')
+makedepends=('cmake' 'ninja' 'python-sphinx' 'python-sphinx_rtd_theme')
backup=("etc/$pkgname/$pkgname.cfg")
source=("https://git.louiz.org/biboumi/snapshot/$pkgname-$pkgver.tar.xz"
'biboumi.tmpfiles'
'biboumi.sysusers')
-md5sums=('d27e81bc3d74bcc9e33fd8c1a6c4ecaf'
+md5sums=('f0a201312454f529bb2a476856264e52'
'3fd509b5cd76cd6c98ddb392957de03b'
'07c92af3248861ce94d361e98cfb7f5c')
@@ -25,21 +25,25 @@ prepare() {
-DCMAKE_INSTALL_PREFIX=/usr \
-DSERVICE_USER=biboumi \
-DSERVICE_GROUP=jabber \
- -Wno-dev
+ -Wno-dev \
+ -G Ninja
}
build() {
- cd build
- make biboumi
+ ninja -C build
+ ninja -C build doc
}
package() {
cd build
- make DESTDIR="$pkgdir/" install
+ DESTDIR="$pkgdir/" ninja install
+
+ install -dm755 "$pkgdir"/usr/share/doc/$pkgname/
+ cp -r html "$pkgdir"/usr/share/doc/$pkgname/
cd ../$pkgname-$pkgver
install -Dm644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
- install -Dm644 doc/biboumi.1.rst "$pkgdir"/usr/share/doc/$pkgname/$pkgname.rst
+ install -Dm644 doc/*.rst "$pkgdir"/usr/share/doc/$pkgname/
install -Dm644 conf/biboumi.cfg "$pkgdir"/etc/$pkgname/$pkgname.cfg
cd ..