summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCarlos Aznarán2024-04-21 14:08:20 -0500
committerCarlos Aznarán2024-04-21 14:08:20 -0500
commita75c6fdb1ff28fea9a85ef0515d35ad2b4ac6648 (patch)
tree622c88846dd2902a86298f5050ce65ef2b7fab5a /PKGBUILD
parent1864622014f2d29f77c91905685cfdb9c8bf0f47 (diff)
downloadaur-bibstuff.tar.gz
Use python instead python2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD38
1 files changed, 19 insertions, 19 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9e207219eba5..ff598b58a190 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,29 @@
+# Contributor: Stefan Husmann <stefan-husmann@t-online.de>
# Contributor: Gour <gour@gour-nitai.com>
-# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
-pkgname=bibstuff
+pkgname=bibstuff
pkgver=1.3.1
pkgrel=1
epoch=1
-pkgdesc="Collection of python2 scripts and modules for interacting with BibTeX style databases of citation references"
-url="http://dschwilk.github.io/bibstuff"
-arch=('any')
-license=('MIT')
-depends=('python2-simpleparse')
-makedepends=('git')
-source=(git+https://github.com/dschwilk/bibstuff#commit=0090c406677a35cfdf790894480a2aee8e319419)
-md5sums=('SKIP')
+pkgdesc="Bibtex database utilities"
+url="https://github.com/dschwilk/bibstuff"
+arch=(any)
+license=(MIT)
+depends=(python-simpleparse)
+makedepends=(python-build python-installer python-setuptools python-wheel git)
+source=(git+${url}.git#commit=bc12fcd62f181f870b185ef9080fe1c386bed6f5)
+md5sums=('c0b2391f18f9bfde7a6018033348abe6')
-package() {
+build() {
cd $pkgname
- python2 setup.py install --root="$pkgdir"
-
- # copying license information
- install -D -m644 license.txt "$pkgdir"/usr/share/licenses/$pkgname/license.txt
+ python -m build --wheel --skip-dependency-check --no-isolation
+}
- # copying readme information
- install -Dm644 README.rst "$pkgdir"/usr/share/doc/$pkgname/README.rst
+package() {
+ cd $pkgname
+ PYTHONPYCACHEPREFIX="${PWD}/.cache/cpython/" python -m installer --destdir="${pkgdir}" dist/*.whl
+ install -Dm 644 README.rst -t "${pkgdir}/usr/share/doc/${pkgname}"
+ install -Dm 644 license.txt -t "${pkgdir}/usr/share/licenses/${pkgname}"
- # copying examples directory
install -d "$pkgdir"/usr/share/doc/$pkgname/examples
cp examples/* "$pkgdir"/usr/share/doc/$pkgname/examples
-}
+} \ No newline at end of file