summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorStefan Husmann2015-06-08 20:27:08 +0200
committerStefan Husmann2015-06-08 20:27:08 +0200
commit5143db02971a73ddae3358d2e8c78cee624b6866 (patch)
tree4917d03bf388b2dba345deb0fa354edcb031b627 /PKGBUILD
downloadaur-5143db02971a73ddae3358d2e8c78cee624b6866.tar.gz
initial version
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2e0add659da5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Contributor: Robson Peixoto <robsonpeixoto@gmail.com>
+# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
+
+pkgname=bibtool
+pkgver=2.59
+pkgrel=1
+pkgdesc="Command line manipulation of BibTeX files."
+arch=('i686' 'x86_64')
+url="http://www.gerd-neugebauer.de/software/TeX/BibTool/"
+license=('GPL')
+depends=('texlive-bin')
+makedepends=('tar')
+source=(http://www.gerd-neugebauer.de/software/TeX/BibTool/BibTool-$pkgver.tar.gz)
+md5sums=('78b892f21ddbd803ac74badffc41a6d3')
+noextract=("BibTool-$pkgver.tar.gz")
+
+prepare() {
+ # bsdtar has strange problems unpackung this, so let's use gnu tar
+ tar xf BibTool-$pkgver.tar.gz
+}
+
+build() {
+ cd "$srcdir/BibTool"
+ autoreconf
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$srcdir/BibTool"
+ install -d "$pkgdir"/usr/bin
+ make INSTALLPREFIX=$pkgdir install
+}