summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDesmond Kabus2020-07-23 00:40:07 +0200
committerDesmond Kabus2020-07-23 00:40:07 +0200
commit584da5317dfc1194e1a018d3ae806da646c0b642 (patch)
tree5e78f470928410d5a1d805b9aeddb01aaa43a27b /PKGBUILD
downloadaur-584da5317dfc1194e1a018d3ae806da646c0b642.tar.gz
Add PKGBUILD
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2a692e603fc9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Desmond Kabus <desmond.kabus@protonmail.com>
+
+pkgbase=bigjubelweb-git
+pkgname=bigjubelweb-git
+_module='bigjubelweb'
+pkgver=0.4.2.r4.g8479a49
+pkgrel=1
+pkgdesc="A web interface for BigJubel"
+url="https://www.kabus.eu/git/bigjubelweb"
+depends=('bigjubel' 'sqlite' 'python' 'python-flask' 'python-werkzeug' 'python-yaml' 'python-click')
+makedepends=('python-setuptools' 'git')
+provides=('bigjubelweb')
+conflicts=('bigjubelweb')
+license=('GPL')
+arch=('any')
+source=("bigjubelweb::git://www.kabus.eu/git/bigjubelweb")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${_module}"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/^v//'
+}
+
+build() {
+ cd "${srcdir}/${_module}"
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}/${_module}"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+}