summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDesmond Kabus2023-08-20 20:54:37 +0200
committerDesmond Kabus2023-08-20 20:54:37 +0200
commite81a41e13a549f30bd66a62c36a637d6e451fe59 (patch)
treedc5805e68913464f14d165208e3e91e019ddc1c7 /PKGBUILD
parente3388ef9ba9dbf03bd42ef172302b1fd0fc2983a (diff)
downloadaur-e81a41e13a549f30bd66a62c36a637d6e451fe59.tar.gz
New Python build commands
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 30c9d3babe18..3e89707aa6e9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,12 +3,12 @@
pkgbase=bigjubelweb-git
pkgname=bigjubelweb-git
_module='bigjubelweb'
-pkgver=0.7.6.r0.g0f7ce11
+pkgver=0.7.6.r7.g95f1c26
pkgrel=1
pkgdesc="A web interface for BigJubel"
url="https://gitlab.com/dkabus/bigjubelweb"
depends=('bigjubel' 'sqlite' 'python' 'python-flask' 'python-werkzeug' 'python-yaml' 'python-click')
-makedepends=('python-setuptools' 'git')
+makedepends=('python-build' 'python-installer' 'python-wheel' 'git')
provides=('bigjubelweb')
conflicts=('bigjubelweb')
license=('GPL')
@@ -23,11 +23,11 @@ pkgver() {
build() {
cd "${srcdir}/${_module}"
- python setup.py build
+ python -m build --wheel --no-isolation
}
package() {
cd "${srcdir}/${_module}"
make DESTDIR="$pkgdir/" install
- python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+ python -m installer --destdir="$pkgdir" dist/*.whl
}