summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authormrxx2018-12-11 21:58:54 +0100
committermrxx2018-12-11 21:58:54 +0100
commite7cc3f438e707c531e6df234ba0f749c2045a17c (patch)
tree36ee94fc5c62e58f67a69d7bede5c1b75442c06b /PKGBUILD
parent1c80d722b735c5bacdfa782085bada8d6d9db8c9 (diff)
downloadaur-e7cc3f438e707c531e6df234ba0f749c2045a17c.tar.gz
Autodetect name of 'Desktop' in user's locale
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8b0633455c50..4a9cdccc0a4d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,12 +3,12 @@
pkgname=biglybt
pkgver=1.7.0.0
-pkgrel=3
+pkgrel=4
pkgdesc="Feature-filled Bittorrent client based on the Azureus project"
arch=('x86_64')
url="https://www.biglybt.com/"
license=('GPL3')
-depends=('desktop-file-utils' 'java-runtime>=9')
+depends=('desktop-file-utils' 'xdg-user-dirs' 'java-runtime>=9')
options=('!strip')
install=$pkgname.install
source=("GitHub_BiglyBT_Installer_$pkgver.sh::https://github.com/BiglySoftware/BiglyBT/releases/download/v$pkgver/GitHub_BiglyBT_Installer.sh")
@@ -32,7 +32,8 @@ package() {
# which creates them a) in the wrong place and b) with wrong paths, therefore
# preventing the start of the program via the launcher)
find ~/.local/share/applications -name $pkgname.desktop -cmin -1 -exec rm {} +
- find ~/Desktop -name $pkgname.desktop -cmin -1 -exec rm -f {} +
+ _user_desktop=$(xdg-user-dir DESKTOP)
+ [ "_user_desktop" ] && find "$_user_desktop" -name $pkgname.desktop -cmin -1 -exec rm -f {} +
cd "$srcdir"/$pkgname