summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMartin T. H. Sandsmark2020-07-20 16:00:22 +0200
committerMartin T. H. Sandsmark2020-07-20 16:00:22 +0200
commitf8cdde4b03f8b0dc4d5fbe8bbbccfc8c8c516283 (patch)
tree0d79d88ae5054b058c7167f0b3c86270c70fa5b8 /PKGBUILD
downloadaur-f8cdde4b03f8b0dc4d5fbe8bbbccfc8c8c516283.tar.gz
init
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7e29bcf88101
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+pkgname=bincalc
+pkgver=1
+pkgrel=1
+pkgdesc='A simple command line calculator for bit fiddling (e. g for reverse engineering)'
+url='https://github.com/sandsmark/bincalc'
+arch=('x86_64' 'i686')
+license=('GPL2')
+makedepends=(gcc)
+depends=(gmp)
+source=("https://github.com/sandsmark/bincalc/archive/${pkgver}.tar.gz")
+sha256sums=('eae53cb18818f4d875686c653c6394af06a8029968661314100067589e277128')
+
+build() {
+ cd bincalc-${pkgver}
+
+ # gnu make and/or gcc are broken
+ LDFLAGS+=,--no-as-needed
+
+ make
+}
+
+package() {
+ cd bincalc-${pkgver}
+ install -D -m755 bincalc -t "${pkgdir}/usr/bin"
+}