summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAllen Zhong2020-06-15 16:00:13 +0800
committerAllen Zhong2020-06-15 16:00:13 +0800
commit5f49eb707c792819e1dce5a064f401a25bc71911 (patch)
tree26b4f0733fec2e9166ddfcde30571b3e7c1da31c /PKGBUILD
parent31c64beafebc9225fbf93682f0c7c9655c80e383 (diff)
downloadaur-5f49eb707c792819e1dce5a064f401a25bc71911.tar.gz
upgpkg: bind-rl 9.16.3-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 17 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8e64a887747a..06f4beb3f5fd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
pkgbase=bind-rl
pkgname=(bind-rl bind-rl-tools)
-_pkgver=9.16.2
+_pkgver=9.16.3
pkgver=${_pkgver//-/.}
pkgrel=1
url='https://www.isc.org/software/bind/'
@@ -25,15 +25,15 @@ source=("https://ftp.isc.org/isc/bind9/${_pkgver}/bind-${_pkgver}.tar.xz"{,.asc}
'localhost.zone'
'localhost.ip6.zone'
'127.0.0.zone')
-sha1sums=('985a6ac0ef8242bfb5e3d11794b612d910f860ac'
- 'SKIP'
- 'c5a2bcd9b0f009ae71f3a03fbdbe012196962a11'
- '9537f4835a1f736788d0733c7996a10db2d4eee4'
- '34d828cf20b425cf49a838926e01470c12083bee'
- '62b06487323dd0d515a4dc659b8ecd193c29107b'
- '6704303a6ed431a29b1d8fe7b12decd4d1f2f50f'
- '52da8f1c0247a11b16daa4e03d920e8f09315cbe'
- '9c33726088342207ad06d33b2c13408290a0c8ad')
+sha256sums=('27ac6513de5f8d0db34b9f241da53baa15a14b2ad21338d0cde0826eaf564f7e'
+ 'SKIP'
+ 'f0423c4ee8495da487e07e9144bec1d25f46a0cd2dfa7cfd7a761ef15bfefc98'
+ '7c0acefcfcc3ae093550caed7ec90fe84bec8f7477459ffa7e71dda76bcbdb2c'
+ 'e08a01d41b18bdb771d534daca99642314939aafdb088e5cfcf0ef2d33f8e7eb'
+ '3f0f8db0a1deae270dd166b4750be7c1041b4b44891176f35a8df7dd55d24d34'
+ '0011708e516128647dd25b59b6ebc465f36e85bbe0a8fbdc3eb04b7f28c2197f'
+ 'c06fc270e32a843c8b6d86335a2ec607d405dfba6875de8d8a9abde39a9e2c17'
+ 'b88fd2b99e7d42d414b329b814b9ff3304fa0ef9c67df81bde235bbfa0f3a3b8')
prepare() {
cd bind-$_pkgver
@@ -50,7 +50,11 @@ prepare() {
build() {
cd bind-$_pkgver
- export CFLAGS+=' -DDIG_SIGCHASE'
+ export CFLAGS
+ # support to chase DNSSEC signature chains
+ CFLAGS+=' -DDIG_SIGCHASE'
+ # compile with gcc10, https://gcc.gnu.org/gcc-10/porting_to.html
+ CFLAGS+=' -fcommon'
./configure \
--prefix=/usr \
--sysconfdir=/etc \
@@ -62,10 +66,10 @@ build() {
--enable-dnsrps \
--enable-rrl \
--with-python=/usr/bin/python \
- --with-geoip2 \
+ --with-maxminddb \
--with-openssl \
--with-libidn2 \
- --with-libjson \
+ --with-json-c \
--with-libxml2 \
--with-lmdb \
--with-libtool