summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChristian Rebischke2016-03-22 17:49:01 +0100
committerChristian Rebischke2016-03-22 17:49:01 +0100
commit4019e1c157183834b1f6ac4c95f92d675d738716 (patch)
tree8bb6716879ad86f901f7a45c7d85da28ce3586d1 /PKGBUILD
parented0a10a59bf73552d4c2435b19b5d9b38da18f26 (diff)
downloadaur-4019e1c157183834b1f6ac4c95f92d675d738716.tar.gz
new version 6.1.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 5 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7788427a3d80..bc444dd51115 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,22 @@
# Maintainer: Christian Rebischke <chris.rebischke[at]archlinux[dot]org>
# Contributor: Levente Polyak <anthraxx[at]archlinux[dot]org>
pkgname='binnavi'
-pkgver=6.0.0
-pkgrel=5
+pkgver=6.1.0
+pkgrel=1
pkgdesc="A binary analysis IDE that allows to inspect, navigate, edit and annotate control flow graphs and call graphs of disassembled code"
arch=('any')
url="https://github.com/google/binnavi"
license=('Apache')
makedepends=('maven' 'apache-ant' 'java-environment>=7')
depends=('java-runtime>=7' 'postgresql')
-source=('https://github.com/google/binnavi/archive/v6.0.0.tar.gz' 'binnavi')
-sha512sums=('93f9e726b1a1a8e6079f09d02ef6bc8a13c7427b92d39fd2b41d6c5e0266eede611d1d0d2a745443f37aa5344d3598c7d8595483ba5f086228f86fefe5da0858'
+source=('https://github.com/google/binnavi/archive/v6.1.0.tar.gz' 'binnavi')
+sha512sums=('1829a7a44966a9c985d63b28b7bfd2c75050f45c46ba9f24e3548a53292e59755c617c1baf9297967c8c32d858b7c926f40f97f06ea744618f5e3794a1f8cb90'
'bb274ca29a994ef8b98aa77e0be745e297bd2f7e65dd394594169ffec3910b4dd4982e353202c6b201472632a3f7b16bd7d905b7006e21d76b7299b78fc7f390')
build(){
cd "${srcdir}/$pkgname-$pkgver"
mvn dependency:copy-dependencies -Dmaven.repo.local="${srcdir}/$pkgname-$pkgver"
- ant -f src/main/java/com/google/security/zynamics/build.xml \
- build-binnavi-fat-jar
+ ant build-binnavi-fat-jar
}
package() {