summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoralienzj2017-06-10 04:30:23 +0800
committeralienzj2017-06-10 04:30:23 +0800
commita6666aa46fb4293fb9e017b59adff09a436d023c (patch)
tree9937c6877ed18e7a1163065ef395cc06526f0902 /PKGBUILD
parent13c3fafd42a29f201d32bbd48a9027d12c4d3487 (diff)
downloadaur-bioawk.tar.gz
change source
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 7 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ab12e71e1c39..b0a4ae8de947 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,21 +8,20 @@ arch=('i686' 'x86_64')
url="https://github.com/lh3/bioawk"
license=('GPL')
provides=("bioawk")
-conflicts=("bioawk")
-source=("git://github.com/lh3/bioawk.git")
-md5sums=('SKIP')
+conflicts=("bioawk" "bioawk-git")
+source=("https://github.com/lh3/bioawk/archive/v1.0.tar.gz")
+md5sums=('a2d0dbb2943b3e0bea96a5360390b656')
prepare() {
- cd "$srcdir/$pkgname"
- echo "1.0.0.r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+ cd "$srcdir/$pkgname-${pkgver}"
}
build() {
- cd "$srcdir/$pkgname"
+ cd "$srcdir/$pkgname-${pkgver}"
make
}
package() {
- cd "$srcdir/$pkgname"
- install -Dm755 bioawk $pkgdir/usr/bin/bioawk
+ cd "$srcdir/$pkgname-${pkgver}"
+ install -Dm755 bioawk "$pkgdir/usr/bin/bioawk"
}