summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFrederic Bezies2016-01-23 22:42:21 +0100
committerFrederic Bezies2016-01-23 22:42:21 +0100
commit07dd2d6f0539ce0e485835b9f810506cd1b724a1 (patch)
treea6e7e59e1886e33b38fe097ceccda94080eac60f /PKGBUILD
parent1d6dc16990ac2e221b3bc9caf1bd0fe5dc7a23b3 (diff)
downloadaur-07dd2d6f0539ce0e485835b9f810506cd1b724a1.tar.gz
adapted to elementaryOS requirements
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 10 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 906afe8b3b0e..e12ab9fd5293 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,16 +2,16 @@
# Contributor : Ivo Nunes <ivoavnunes at gmail dot com>
_pkgname="birdie"
pkgname="${_pkgname}-git"
-pkgver=1.1+git.21.gf235c55
-pkgrel=2
+pkgver=1.1+git.30.g8f149f7
+pkgrel=1
pkgdesc="Twitter client for Linux"
arch=('i686' 'x86_64')
url="http://birdieapp.github.io"
license=('GPL3')
-depends=('glib2' 'gtk3' 'hicolor-icon-theme' 'python2-requests'
-'python2-requests-oauthlib' 'pygtksourceview2' 'python2-pillow'
-'gtksourceview3' 'webkitgtk' 'python2-socksipy-branch' 'python2-gobject')
-makedepends=('git' 'desktop-file-utils' 'hicolor-icon-theme' 'intltool' 'yelp-tools' 'gnome-common' 'gobject-introspection')
+depends=('glib2' 'gtk3' 'hicolor-icon-theme' 'vala' 'granite-bzr' 'libpurple'
+'gtksourceview3' 'libdbusmenu-gtk3')
+makedepends=('git' 'desktop-file-utils' 'hicolor-icon-theme' 'intltool'
+'yelp-tools' 'gnome-common' 'gobject-introspection')
options=('!libtool')
conflicts=('birdie' 'birdie-bzr')
provides=('birdie')
@@ -26,13 +26,14 @@ pkgver() {
build() {
cd "${_pkgname}"
- export PYTHON=`which python2`
- ./autogen.sh --prefix=/usr
+ mkdir build
+ cd build
+ cmake .. -DCMAKE_INSTALL_PREFIX=/usr
make
}
package() {
cd "${_pkgname}"
+ cd build
make DESTDIR="${pkgdir}/" install
- sed -i 's|/usr/bin/env python|/usr/bin/python2|' ${pkgdir}/usr/bin/birdie
}