summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJonathon Fernyhough2018-12-21 21:51:40 +0000
committerJonathon Fernyhough2018-12-21 21:51:40 +0000
commit7a106e52adbba9d8ccedb696b2b71ced5dc1a53a (patch)
treed0889bc0379509d4042daef243ce838056379d09 /PKGBUILD
parentdb06f87551ed624d3b5a8ccf327298554fd1d4e5 (diff)
downloadaur-7a106e52adbba9d8ccedb696b2b71ced5dc1a53a.tar.gz
Release 1.4. Add birdtray.desktop (thanks ValHue!).
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 11 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 37403fdb8838..5677a0a5aaff 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,18 @@
# Maintainer: Jonathon Fernyhough <jonathon_at_manjaro dot+org>
+# Contributor: Valentin Huélamo (birdtray.desktop)
pkgname=birdtray
-pkgver=1.3
+pkgver=1.4
pkgrel=1
pkgdesc="Run Thunderbird with a system tray icon."
arch=('i686' 'x86_64' 'armv7h' 'armv6h' 'aarch64')
url="https://github.com/gyunaev/birdtray"
license=('GPL')
depends=(qt5-x11extras sqlite3)
-source=("${pkgname}-${pkgver}.tar.gz::https://github.com/gyunaev/$pkgname/archive/${pkgver}.tar.gz")
-sha1sums=('8503fd1b3792659a866c2343a54e00db28d51691')
+source=("${pkgname}-${pkgver}.tar.gz::$url/archive/${pkgver}.tar.gz"
+ birdtray.desktop)
+sha1sums=('187b38bbc88e54ce701fe49218298b5172a5c053'
+ 'f3398822d8cf6671f06b5e065b623083294d6f11')
build() {
mkdir -p build && cd build
@@ -18,13 +21,13 @@ build() {
}
package() {
- cd build
-
install -d "$pkgdir"/usr/bin
install -d "$pkgdir"/usr/lib/birdtray
install -d "$pkgdir"/usr/include/birdtray
+ install -d "$pkgdir"/usr/share/applications
- install birdtray "$pkgdir"/usr/bin/birdtray
- install -m644 *.o "$pkgdir"/usr/lib/birdtray/
- install -m644 *.h "$pkgdir"/usr/include/birdtray/
+ install birdtray.desktop "$pkgdir"/usr/share/applications/birdtray.desktop
+ install build/birdtray "$pkgdir"/usr/bin/birdtray
+ install -m644 build/*.o "$pkgdir"/usr/lib/birdtray/
+ install -m644 build/*.h "$pkgdir"/usr/include/birdtray/
}