summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJonathon Fernyhough2020-07-13 11:04:09 +0100
committerJonathon Fernyhough2020-07-13 11:04:09 +0100
commitec46e9efae7bef720d1c8e2b8892891d411fbbea (patch)
treeb030bf5748eed20fb30e853029fa4c9b8faa8329 /PKGBUILD
parentd373b4581100014210a96dc115f74d560fd99c4e (diff)
downloadaur-ec46e9efae7bef720d1c8e2b8892891d411fbbea.tar.gz
Cherry-pick commit to fix compilation with Qt 5.15
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 12 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 78d57a7626c8..8532b520a05d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,8 +13,18 @@ license=('GPL-3.0')
depends=(qt5-svg qt5-x11extras)
optdepends=('qt5-translations: Support for translations')
makedepends=(cmake qt5-tools)
-source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
-sha1sums=('805cfa9f30af71c268160068bb53ccde618244e8')
+source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz"
+ "$url"/commit/38b333b5ff9318ae136d719c5fdd4c790c294833.diff)
+sha1sums=('805cfa9f30af71c268160068bb53ccde618244e8'
+ 'd33f43ecc342cdfa36ce7783ccad6c35b57c50f1')
+
+prepare() {
+ cd $pkgname-$pkgver
+
+ # "Fixed compilation on Qt 5.15",
+ # https://github.com/gyunaev/birdtray/commit/38b333b5ff9318ae136d719c5fdd4c790c294833
+ patch -Np1 -i ../38b333b5ff9318ae136d719c5fdd4c790c294833.diff
+}
build() {
mkdir -p build && cd build