summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDavid Parrish2017-07-07 16:51:03 -0400
committerDavid Parrish2017-07-07 16:51:03 -0400
commit1f0809e987c2d2ee699a28306863814e979145d8 (patch)
tree96cd8df93479e69ff8977bf30c847cd2cb499acf /PKGBUILD
parentf002430c228346738182ba6eeef33302add8f210 (diff)
downloadaur-1f0809e987c2d2ee699a28306863814e979145d8.tar.gz
Create bisq-git PKGBUILD version
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 10 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 10d58d50a8ee..74678b4077bf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: David Parrish <daveparrish@tutanota.com>
-pkgname=bisq
-pkgver=0.5.1
+pkgname=bisq-git
+pkgver=0.5.1.r0.gbaa03c437
pkgrel=1
pkgdesc="Cross-platform desktop application that allows users to trade national currency (dollars, euros, etc) for bitcoin without relying on centralized exchanges"
arch=('any')
@@ -10,9 +10,9 @@ license=('AGPL3')
depends=('java-openjfx')
makedepends=('maven' 'jdk8-openjdk' 'protobuf')
source=("${pkgname}::git+https://github.com/bitsquare/bitsquare.git#tag=v${pkgver}"
- "git+https://github.com/bitsquare/bitcoinj.git#commit=c7aee7e0d91ca3d84281156ee2b2b9fddc3a8d56"
- "git+https://github.com/bitsquare/libdohj.git#commit=b88940e29cbae01619fbd091df92935b326d94e7"
- "git+https://github.com/bitsquare/btcd-cli4j.git#commit=9d7ff85ab450b96c890e569dc9b584eae7bf13ad"
+ "git+https://github.com/bitsquare/bitcoinj.git#branch=bisq_0.14.4.1"
+ "git+https://github.com/bitsquare/libdohj.git#branch=master"
+ "git+https://github.com/bitsquare/btcd-cli4j.git#commit=master"
"bisq.sh"
"bisq.desktop")
sha256sums=('SKIP'
@@ -22,6 +22,11 @@ sha256sums=('SKIP'
'175e18841dd216ca84391a89b0fba0b12bf575ec095d200ae9a3babc83693e31'
'2f9da2f32bb7d023af78bcbf688bc8dc01f24e1d6c7e3227928e22338343587c')
+pkgver() {
+ cd "$pkgname"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
prepare() {
msg 'Fixing protoc path...'
sed -i 's#/usr/local/bin/protoc#/usr/bin/protoc#g' "$pkgname/common/pom.xml"