summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFelipe F. Tonello2016-07-22 15:28:35 +0100
committerFelipe F. Tonello2016-07-22 15:28:35 +0100
commitacd7b27cd92c8f1c0796a66666ec78865f754fb1 (patch)
tree42d1c2afec123ec52237d4450ca333714013d65d /PKGBUILD
parentc701f9287aa9881e804ede489fef8873cc0ff607 (diff)
downloadaur-acd7b27cd92c8f1c0796a66666ec78865f754fb1.tar.gz
Improved package to remote sudo pip2 command
It is very bad practice to use sudo whatever command in a package meta-data. To solve this issue I had to create another package called python-codegen that support the proper dependency. Reported-by: Scimmia <scimmia@archlinux.info> Signed-off-by: Felipe F. Tonello <eu@felipetonello.com>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 9 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b84dc11d9ea9..ecacde7204fd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,27 +4,22 @@
pkgbase=bitbake
pkgname=('bitbake' 'bitbake-vim')
pkgver=1.30
-pkgrel=2
+pkgrel=3
pkgdesc="Build tool executing tasks and managing metadata."
+arch=('any')
url="http://openembedded.org"
-makedepends=('python2-pip' 'gzip')
license=('GPL2')
-arch=('any')
-source=("https://github.com/openembedded/${pkgbase}/archive/${pkgver}.zip")
+makedepends=('python2' 'python2-progressbar' 'python2-ply' 'python2-pyinotify' 'python2-beautifulsoup4' 'python2-codegen')
+source=(https://github.com/openembedded/${pkgbase}/archive/${pkgver}.zip)
md5sums=('bb883123767ecb0451d80d20c7e9cea7')
-prepare() {
- echo "It is necessary root access to install codegen python package via pip2"
- sudo pip2 install codegen
-}
-
check() {
cd ${srcdir}/${pkgbase}-${pkgver}/bin
PYTHONPATH=`pwd`/../lib ./bitbake-selftest
}
package_bitbake() {
- depends=('python2' 'python2-progressbar' 'python2-ply' 'python2-pyinotify' 'python2-beautifulsoup4' 'python2-pip')
+ depends=('python2' 'python2-progressbar' 'python2-ply' 'python2-pyinotify' 'python2-beautifulsoup4' 'python2-codegen')
install=bitbake.install
cd ${srcdir}/${pkgbase}-${pkgver}
@@ -38,11 +33,11 @@ package_bitbake() {
install -d ${pkgdir}/usr/share/man/man1
install doc/bitbake.1 ${pkgdir}/usr/share/man/man1
- gzip ${pkgdir}/usr/share/man/man1/bitbake.1
+ #gzip ${pkgdir}/usr/share/man/man1/bitbake.1
- install -d ${pkgdir}/usr/share/licenses/${pkgbase}
- install -m 644 LICENSE ${pkgdir}/usr/share/licenses/${pkgbase}
- install -m 644 COPYING ${pkgdir}/usr/share/licenses/${pkgbase}
+ #install -d ${pkgdir}/usr/share/licenses/${pkgbase}
+ #install -m 644 LICENSE ${pkgdir}/usr/share/licenses/${pkgbase}
+ #install -m 644 COPYING ${pkgdir}/usr/share/licenses/${pkgbase}
}
package_bitbake-vim() {