summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFelipe F. Tonello2016-07-21 15:50:50 +0100
committerFelipe F. Tonello2016-07-21 15:50:50 +0100
commitb9cc0c8332e1677c2d9ee6e9ca1c3e0262efb976 (patch)
tree78ed537831e40048efba3c8a5d7e04223eedc953 /PKGBUILD
downloadaur-b9cc0c8332e1677c2d9ee6e9ca1c3e0262efb976.tar.gz
Initial version of bitbake support for Arch
This PKGBUILD contains two packages: - bitbake: containing all binaries and libraries necessary to run bitbake. - bitbake-vim: Vim related files to assist on recipes editing. TODO: support toaster via a bitbake-toaster package.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD52
1 files changed, 52 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b01e9c94d4c2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,52 @@
+# Maintainer: Felipe F. Tonello <eu@felipetonello.com>
+# TODO: support Toast
+
+pkgbase=bitbake
+pkgname=('bitbake' 'bitbake-vim')
+pkgver=1.30
+pkgrel=1
+pkgdesc="Build tool executing tasks and managing metadata."
+url="http://openembedded.org"
+makedepends=('python2-pip' 'gzip')
+license=('GPL2')
+arch=('any')
+source=("https://github.com/openembedded/${pkgbase}/archive/${pkgver}.zip")
+md5sums=('bb883123767ecb0451d80d20c7e9cea7')
+
+prepare() {
+ pip2 install codegen
+}
+
+check() {
+ cd ${srcdir}/${pkgbase}-${pkgver}/bin
+ PYTHONPATH=`pwd`/../lib ./bitbake-selftest
+}
+
+package_bitbake() {
+ depends=('python2' 'python2-progressbar' 'python2-ply' 'python2-pyinotify' 'python2-beautifulsoup4' 'python2-pip')
+ install=bitbake.install
+
+ cd ${srcdir}/${pkgbase}-${pkgver}
+
+ install -d ${pkgdir}/usr/bin
+ install bin/bitbake* ${pkgdir}/usr/bin
+
+ install -d ${pkgdir}/usr/lib/python2.7/site-packages
+ cp -Ra lib/bb ${pkgdir}/usr/lib/python2.7/site-packages
+ cp -Ra lib/prserv ${pkgdir}/usr/lib/python2.7/site-packages
+
+ install -d ${pkgdir}/usr/share/man/man1
+ install doc/bitbake.1 ${pkgdir}/usr/share/man/man1
+ gzip ${pkgdir}/usr/share/man/man1/bitbake.1
+
+ install -d ${pkgdir}/usr/share/licenses/${pkgbase}
+ install -m 644 LICENSE ${pkgdir}/usr/share/licenses/${pkgbase}
+ install -m 644 COPYING ${pkgdir}/usr/share/licenses/${pkgbase}
+}
+
+package_bitbake-vim() {
+ cd ${srcdir}/${pkgbase}-${pkgver}
+
+ install -d ${pkgdir}/usr/share
+ cp -Ra contrib/vim ${pkgdir}/usr/share
+}