summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTomZ2016-12-22 22:01:49 +0100
committerTomZ2016-12-22 22:01:49 +0100
commit1220b923db456f8f3f36150c868ba3d3516e5e10 (patch)
tree232f52ec276498d6029a86ecf73e39d311100f2c /PKGBUILD
parent6de6b00975690b042e03d62ce7ba7b67279da4ef (diff)
downloadaur-1220b923db456f8f3f36150c868ba3d3516e5e10.tar.gz
Made the running as daemon part work properly
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 10 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e767282ac835..b312458cb99c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Tom Zander
pkgname=bitcoin-classic-git
-pkgver=v1.2.0.b1
+pkgver=v1.2.0.b1.r56.gd5556713
pkgrel=1
pkgdesc='Bitcoin Classic versions of Bitcoind, bitcoin-cli, bitcoin-tx, and bitcoin-qt, most recent stable branch, w/GUI and wallet'
arch=('i686' 'x86_64')
@@ -11,11 +11,14 @@ depends=('boost-libs' 'desktop-file-utils' 'libevent' 'qt5-base' 'protobuf' 'ope
makedepends=('boost' 'qt5-tools')
provides=('bitcoin-daemon' 'bitcoin-cli' 'bitcoin-qt' 'bitcoin-tx')
conflicts=('bitcoin-daemon' 'bitcoin-cli' 'bitcoin-qt' 'bitcoin-tx')
-install=bitcoin-qt.install
+install=bitcoin.install
source=("git+https://github.com/bitcoinclassic/bitcoinclassic.git#branch=develop"
- "bitcoin.logrotate")
+ "bitcoin.logrotate"
+ "bitcoin.conf")
+
sha256sums=('SKIP'
- "7bf4bdad419c1ee30b88c7e4190707c5ff250da8b23d68d5adf14043f8e2ac73")
+ "7bf4bdad419c1ee30b88c7e4190707c5ff250da8b23d68d5adf14043f8e2ac73"
+ "c8787560c6423605796c8d3e080cb522ed849cea12b5c23293c22e405a015a53")
pkgver() {
cd "$srcdir/bitcoinclassic"
@@ -54,16 +57,15 @@ package() {
msg2 'Installing bitcoin-daemon...'
install -Dm755 "$srcdir/bitcoinclassic/src/bitcoind" "$pkgdir/usr/bin/bitcoind"
install -Dm644 "$srcdir/bitcoinclassic/contrib/debian/examples/bitcoin.conf"\
- "$pkgdir/usr/share/doc/$pkgname/examples/bitcoin.conf"
+ "$pkgdir/usr/share/doc/bitcoin/examples/bitcoin.conf"
install -Dm644 "$srcdir/bitcoinclassic/contrib/debian/manpages/bitcoind.1"\
"$pkgdir/usr/share/man/man1/bitcoind.1"
install -Dm644 "$srcdir/bitcoinclassic/contrib/debian/manpages/bitcoin.conf.5"\
"$pkgdir/usr/share/man/man5/bitcoin.conf.5"
msg2 'Installing bitcoin.conf...'
- # Install bitcoin.conf is one does not already exist
- [[ ! -e "/etc/bitcoin/bitcoin.conf" ]] && install -Dm 644 \
- "$srcdir/bitcoinclassic/contrib/debian/examples/bitcoin.conf" -t "$pkgdir/etc/bitcoin"
+ install -Dm 644 "$srcdir/bitcoin.conf" "$pkgdir/etc/bitcoin/bitcoin.conf.dist"
+ install -Dm 644 "$srcdir/bitcoinclassic/share/rpcuser/rpcuser.py" "$pkgdir/etc/bitcoin/rpcuser.py"
msg2 'Installing bitcoin.service...'
install -Dm 644 "$srcdir/bitcoinclassic/contrib/init/bitcoind.service" \