summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorUncle Hunto2017-09-11 11:09:17 -0700
committerUncle Hunto2017-09-11 11:09:17 -0700
commit665066b4626c1f5dbdf3150934ff3ba1e463a340 (patch)
tree8d72491312abd00ea04d2d5dad77d09a84c5b9d6 /PKGBUILD
parent85523f466e6af9367bf50c16da2701e0a3f28631 (diff)
downloadaur-665066b4626c1f5dbdf3150934ff3ba1e463a340.tar.gz
Update to 0.15, re-enable unit tests now that all are working
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 4 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c14762ded517..115f73011c18 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
# Maintainer: Uncle Hunto <unclehunto äτ ÝãΗ00 Ð0τ ÇÖΜ>
-## Build from latest stable tag
+## Build from latest tag
#_tag=$(git ls-remote -t --refs https://github.com/bitcoin/bitcoin.git | awk '{print $2}' | LC_ALL=C sort -bfV | sed '/rc[0-9]/d' | tail -n1 | sed -n -e 's/^.*tags\///p')
pkgname=bitcoin-gui-git
-pkgver=v0.14.2.r42.g91be5e3c1
+pkgver=v0.15.0.r0.g3751912e8
pkgrel=1
pkgdesc='Most recent stable branch, UPNP disabled, w/ Bitcoin binaries, dev tools, GUI, and wallet'
arch=('i686' 'x86_64')
@@ -15,7 +15,7 @@ optdepends=('db4.8: Wallet portability/compatibility w/official binaries')
provides=('bitcoin-daemon' 'bitcoin-cli' 'bitcoin-qt' 'bitcoin-tx')
conflicts=('bitcoin-daemon' 'bitcoin-cli' 'bitcoin-qt' 'bitcoin-tx')
install=bitcoin-qt.install
-source=('git+https://github.com/bitcoin/bitcoin.git#branch=0.14'
+source=('git+https://github.com/bitcoin/bitcoin.git#branch=0.15'
'bitcoin-qt.install')
sha256sums=('SKIP'
'ebf7090ca1202e2c2ccd1aa5bb03e6ac911c458141a1cedda9b41f9c26c2602c')
@@ -34,8 +34,7 @@ build() {
./autogen.sh
./configure --prefix=/usr --with-incompatible-bdb --with-gui=qt5 --without-miniupnpc
make -j$(nproc)
- ## Commented out until unit test is fixed to work with segwit
- #make -j$(nproc) check
+ make -j$(nproc) check
}